PDA

View Full Version : LW 2015 Bullet Dynamics not working?



Stardust
01-02-2019, 10:29 AM
Hi,

I was trying to learn about Dynamics... Have been sitting here for a few hours.

I follow the tutorial in the Docs and also other tutorials online....

BUT
Nothing Moves!!!! :(

From what I gather, one is to select the object which one wants to move and then click "Dynamic Body -> Rigid body" , move the object to the starting point and then when pressing play it should fall....

Am I supossed to do some hidden magic before the Tutorials?


Thnx and Happy New Year

MonroePoteet
01-02-2019, 11:58 AM
If the object you want as a Rigid Body is subpatched, be sure that Subdivision Order for the object is Last. Otherwise, the subdivisions are done before the Bullet physics is applied and they stay where they were generated.

143766

mTp

prometheus
01-02-2019, 12:01 PM
What tutorial?
impossible to follow if we do not know which one? your simple description isnīt enough.

Load the scene contents which covers bullet dynamics and try those first, study them.
make sure enable dynamics is highlighted in blue in the fx tool/bullet menu.

MonroePoteet
01-02-2019, 12:35 PM
Sorry, my advice re:subdivision order is only applicable to Parts Bodies. A Rigid Body should be affected by Bullet even if it's subpatched.

mTp

Stardust
01-02-2019, 02:12 PM
What tutorial?
impossible to follow if we do not know which one? your simple description isnīt enough.

Load the scene contents which covers bullet dynamics and try those first, study them.
make sure enable dynamics is highlighted in blue in the fx tool/bullet menu.

The one in the LW Docs, page 796 , and
This https://www.youtube.com/watch?v=EHxFSnLJ78c
this ... https://www.youtube.com/watch?v=FjeTQI9WE0w

nothing moves...

Stardust
01-02-2019, 02:48 PM
The one in the LW Docs, page 796 , and
This https://www.youtube.com/watch?v=EHxFSnLJ78c
this ... https://www.youtube.com/watch?v=FjeTQI9WE0w

nothing moves...

Nevermind.... I just restarted LW and it works now....

prometheus
01-02-2019, 03:28 PM
Nevermind.... I just restarted LW and it works now....

Thatīs why I think you may have accidently clicked or turned of activation of bullet dynamics.
Once rebooting, all those settings should be active by default and it is ergo restored upon reboot.
Sometimes you may want to turn of dynamics when moving items around so it doesnīt auto calculate the dymacis until you hit play, otherwise it may slow the setting up of the scene.

Stardust
01-04-2019, 08:16 PM
Thatīs why I think you may have accidently clicked or turned of activation of bullet dynamics.
Once rebooting, all those settings should be active by default and it is ergo restored upon reboot.
Sometimes you may want to turn of dynamics when moving items around so it doesnīt auto calculate the dymacis until you hit play, otherwise it may slow the setting up of the scene.

thnx