PDA

View Full Version : Normal and bump maps not with GI



Andy Webb
12-19-2018, 08:16 AM
Below show the problem I'm seeing with Interpolated GI and both normal maps and bump maps.

I've tried uping the rays to 10000 and still no difference :(

143650143651143652

MonroePoteet
12-19-2018, 02:05 PM
I'm unable to reproduce this, so it may be the specific bump / normal maps you're using, or their scale in the texture layer, etc. What kind of lighting is in the scene? Do you have an Image World or Textured Environment environment set up with an Environment Light? Maybe some sort of stippling / moire pattern from the environment?

mTp

Andy Webb
12-19-2018, 04:48 PM
Below show the problem I'm seeing with Interpolated GI and both normal maps and bump maps.

I've tried uping the rays to 10000 and still no difference :(

143650143651143652

No nothing like that, 4 area lights and GI, that's it.

I've tried it with other normal maps and bump maps and get a similar issue.

Straight Monte Carlo works a treat.

MonroePoteet
12-19-2018, 04:53 PM
Huh. Here's a render with both Bump and Normal maps on the floor, Interpolated GI and an Environment Light. Looks good to me:

143657

143658

mTp

jwiede
12-19-2018, 07:28 PM
Huh. Here's a render with both Bump and Normal maps on the floor, Interpolated GI and an Environment Light. Looks good to me:

143657

143658

Well, the other scene has multiple light sources, and the way the car "overhangs" the ground plus the tires (& legs) make for complex light paths/occlusions. Your scene might be too simple in light pathing to replicate the issue. The OP's light-colored, matte-ish ground surface also is likely to make GI blotchiness more visible.

Sensei
12-19-2018, 09:47 PM
Straight Monte Carlo works a treat.

Can you show how it should looks like without interpolation?

Andy Webb
12-20-2018, 04:20 AM
Here's a render using just 5 rays brute force GI and the 4 area lights, looks fine to me.

What is odd is the brute force setting of 5 rays is what I have set when using inerpolated, but that seems to have been ignored when I render...

143660

Sensei
12-20-2018, 05:06 AM
Here's a render using just 5 rays brute force GI and the 4 area lights, looks fine to me.

Use 1000+ and try again..

Andy Webb
12-20-2018, 05:10 AM
Use 1000+ and try again..

I've been up to 50000 and no difference :(

- - - Updated - - -

Just tried a normal map from the 2018 content and no difference.

Andy Webb
12-20-2018, 05:49 AM
Here's a 2015 v 2018 test, same GI settings.


143661143662

- - - Updated - - -

I'm thinking of perhaps re-installing 2018.0.7? :(

Andy Webb
12-20-2018, 06:59 AM
Well I've re-installed LW2018.0.7 and it's solved a couple of other issues but not the normal map issue.

What I have noticed is that MonroePoteet had the interpolated softness set to 50, so I changed my low setting to 50 and there is a vast improvement.

I have kept it low in the past as I felt it tended to soften the render.

So perhaps that's the key with this issue.

Cheers

RebelHill
12-20-2018, 08:16 AM
Ah... no leave interpolation softness between 40-60. Any lower just creates a splotchfest, and higher a circlefest. It doesnt soften the render in anyway, only the spatial smoothing of the GI solution.

Andy Webb
12-20-2018, 09:35 AM
Well thanks to everyone for looking at this, at least it's resolved! :thumbsup:

RPSchmidt
12-20-2018, 10:40 AM
You mentioned you were using four area lights... what are your light samples? Perhaps bump up your samples from the default 4 samples to say, 24 or so.

Also, is normalization on in your area lights?

Just some thoughts.

Andy Webb
12-20-2018, 10:57 AM
You mentioned you were using four area lights... what are your light samples? Perhaps bump up your samples from the default 4 samples to say, 24 or so.

Also, is normalization on in your area lights?

Just some thoughts.

tried all of that, I think the interpolated softness was/is the key :)