View Full Version : Problems with Modeler

07-31-2018, 02:22 PM
I have the 2015 version of LW.

I have not used it for a while, but I certainly have not forgotten how to build objects in Modeler! But for some reason, the program is acting wonky....

When I have an object in Layer 1, then highlight Layer 2 (empty) and load another object into that layer, I receive the message: "Do you want to discard your changes to (object name that is being loaded)?" I get a "Yes" or "No" option. I tried it again, and the message does not appear, but the object does not load at all.

I have gone to a second layer sometimes and tried to open an object, and it does load, but loads back into the first layer, displacing whatever was there! I cannot build any objects, as I can't load multiple files (objects) into Modeler.

I have NEVER seen this before in all the 20+ years that I have been using the program!

Any ideas as to what's going on with the program?


Larry A.

Tim Parsons
07-31-2018, 02:34 PM
I never use that workflow so I can't tell you what's up. Here's what I do - load the object that you want to "steal" stuff from like you normally would and then copy and past the components you want into the other object layer.

07-31-2018, 03:01 PM
Thanks, Tim -- but maybe I wasn't clear in my description.

I don't want to "steal" anything; I'm attempting to construct objects as I have for years and years. Actually, apparently I cannot even copy and paste from one layer to another. Something in the program is totally jacked up, I believe. Wondering if I have to remove the program and reinstall -- perhaps a Windows update has messed up LightWave!

07-31-2018, 03:02 PM
This seems to work fine for me in LW2015.3. All the Objects I'm loading into Layers are saved to disk at the time.

It sounds like you may be trying to load an Object into the layer which is already open in Modeler and has had changes made to it. Try making sure that all the Objects are saved to disk before you use Load Object Into Layer.


07-31-2018, 04:22 PM
I have saved all the objects created in Modeler. The problems occur when I re-load them into the program!

As stated, I have been using LightWave for more than 20 years (I started with version 3.0), and have never experienced this situation.

Obviously, there is a glitch somewhere, and I was wondering if anyone else has experienced problems. I last used the program about 3 or 4 months ago, and it worked perfectly.

Larry A.

07-31-2018, 04:47 PM
Also make sure the models you are trying to load are not LW2018 models, for example perhaps some newer scenes / objects you've downloaded from the forum.

It doesn't sound like the issue, but when I first started testing this in LW2015, I erroneously had my content folder set to my LW2018 folder and got very wierd behavior. When loading directly with Load Object, I'd get an error popup:


but when trying to use Load Object Into Layer, I'd get no error, a "Save Changes" query, and no loaded geometry.

Otherwise, I don't have any suggestion. As I said, it works for me.


07-31-2018, 04:53 PM
Are the objects you are trying to load into a layer, are the also layered objects? Because I get that message if I try to load layered objects. Which makes sense to me since those layers have to go somewhere and will over-ride what's already there.

08-01-2018, 02:28 PM
Hey there, Larry!
You doing well?

Don't understand your problem. Are you wanting to load objects into a layer? There's a load command for that.

Copy paste... as long as you are in polygon mode, copying of objects just ought to work.

Sounds like a bit of kitbashing.
Good luck,

08-02-2018, 12:27 AM
??? Sounds like you are loading THE SAME OBJECT/FILE, twice.

IOW, you've loaded "Xobject.lwo", switched to Layer 2, and attempt to load "Xobject.lwo" again. These steps exactly replicate your experience (in 2018).


Interestingly, and a total red herring, if you use LOAD OBJECT INTO LAYER on the same object, first you'll get an alert asking if you want to save the object, then you get an error:

There's no need to LOAD a file twice (and apparently Modeler doesn't like it), just COPY/PASTE. Or make a "file copy" of your object, and load that. But really, it's pointless.

08-05-2018, 02:53 PM
Hi, Robert! Thanks for getting in touch.

I thought I made this problem very clear, but I'll try again! In the past (since FOREVER!), I could build models in Modeler by working on an object, then saving it. If I wanted to add to the object, I could load the original into Layer 1; then highlight Layer 2 and load a second object into that layer. I could then (if I wished) highlight BOTH layers, hit CTRL-x and everything would disappear, then hit CTRL-V and both objects would be conjoined and show up in Layer 1.

Now, I load an object into Layer 1 (so far, so good); then I highlight Layer 2 and go to "Load Object," select what I want to load into Layer 2 and Enter. But now, instead of loading the second object into the highlighted Layer 2, it puts it into Layer 1, and the object that was originally in Layer 1 disappears! Evidently, I can no longer load pieces of objects into multiple layers.

Just total weirdness. I tried completely uninstalling LightWave (I'm using version 2015.3) and then re-installing it, hoping that the problem would be resolved. Nope. Same issue.

Very exasperating! You know that I have been a LightWave user for more than 20 years now (since version 3 on the Amiga), so I'm no novice. I have done plenty of modeling in my time, but I have never had this issue before. Don't know what to do.... sure wish there was a phone number to call a Tech and have him/her talk me through possible remedies!

08-05-2018, 10:40 PM
FWIW, I don't ever remember it working this way.

08-06-2018, 01:02 PM
Me neither... Can't you use the Load into Layer command?


08-06-2018, 06:01 PM
You have me incredibly puzzled. The way "Load Object" has always worked for me in Modeler is to load an additional object. Modeler is multi-document, so you can work on multiple objects at the same time, independently of each other. I can then switch between those two objects on the Object dropdown menu (image below), and if they have multiple layers I can copy and paste layers from one into the other if I choose.


I can pick an empty layer before using "Load Object" but it doesn't load the object into that layer, it loads it into its own workspace. There is no error message about discarding changes.

On the other hand, "Load Object into Layer..." which is right below "Load Object" on the default Load menu dropdown, does what you describe.


Pick a layer, "Load Object into Layer" and the object loads into that layer, essentially becoming a new layer of whatever object you are working on. For example, load the DinosaurOpenGL object from content, pick a layer, "Load Object into Layer" and select the Mecha_Wasp object. then select both layers to make them both visible:


So...I have no idea what to tell you about the experience you are describing.

OK, wait, there was one thing I didn't do...Ok, yes, if I try to "Load Object" with an already loaded object, then I get the message asking if I want to discard all changes I have made to the object. If I say yes then it loads the object, if I made changes that I didn't save, those are lost.

If I use "Load Object into Layer" with an already loaded object, there is no problem loading that into another object that is also open. I had both Dino and Wasp loaded when I did a "Load Object into Layer" and put the Wasp in a Layer of the Dino object.

However, trying to load an object into a layer of itself fails; there is a requester that asks if you want to save changes first, even if you have made none. You can Save, Cancel, Don't Save; Cancel cancels with no problem, Save and Don't Save both produce an error message and the object document closes.

So, seems like you can do what you want to do, but it is "Load Object into Layer" that gets you there, provided you aren't trying to load the object you are actually working on into a layer of itself. Making a copy of it with a different name solves that.

08-07-2018, 11:54 AM
I think I've seen that problem but have never been able to isolate it or been able to repeat it. It could be "operator error."

I usually build complex objects in parts; wheels and tires, chassis, driver compartment, etc, and then bring them together as one object. So I use "Load Object into Layer" and "Save Layers as Object" a lot. Once in a while LW will crash or I get the message Larry mentioned. I've seen this since v9. It seems to happen more often when I have a long session of loading/saving objects from layers.

Wish I could explain this better -- at least come up with a workflow that causes the problem more often.