PDA

View Full Version : Smoothing in modeler and layout?



SLAYER
12-30-2003, 12:29 AM
If I have different parts on layers with different surfaces applied some of them get weird looking color/shadow type issues in modeler which carries over to the render.

I am able to fix the majority of these individual surfaces by changing the smoothing in the surfaces panel. Is that what I should do? Some of these do not seem to really go away until I crank it up to like 330%. Some do not completely go away at all.


Thanks.

toby
12-30-2003, 01:37 AM
Not sure what you mean but basically -

smoothing does not go from one object to another, there must be common points. Smoothing will however go from surface to surface if a part of the same mesh.

Smoothing errors occur from non-planars, overlapping polygons, degenerate polygons, overlapping points, and from setting the smoothing threshold too high. Models need to be built with smoothing in mind.

I have a brief tutorial that will clarify it a bit:
http://www.tobygaines.com/bevel.html

Post a pic if you still have trouble -

SLAYER
12-30-2003, 11:31 AM
Thanks again Toby.
Here are three pics.

Pic one is wire/shade showing the triples to all my non-planars.

Pic two is just one smoothing error section at the default 89.5.

Pic three is a render after tweaking some of the surface smoothness to 330% which is where it looked the most normal in modeler.

Thanks

SLAYER
12-30-2003, 11:31 AM
two

SLAYER
12-30-2003, 11:32 AM
three

toby
12-30-2003, 01:01 PM
Nice model!

Unfortunately triangles don't smooth the same way as quads. Although tripling will fix your non-planars, it's better to avoid bending quads in the first place.

I would make the top part over again with just quads.

The smoothing angle is where you tell the renderer to stop smoothing, the default is just under 90 degrees so that a perfect cube, for example, won't have it's sides smoothed.

Smoothing is a lot like splines, it's a curve calculated by 3 points - if you want a tight curve you need three points close together, which is what the extra slices near the corner are for.

SLAYER
12-30-2003, 02:17 PM
Originally posted by toby
Nice model!

Unfortunately triangles don't smooth the same way as quads. Although tripling will fix your non-planars, it's better to avoid bending quads in the first place.

I would make the top part over again with just quads.

The smoothing angle is where you tell the renderer to stop smoothing, the default is just under 90 degrees so that a perfect cube, for example, won't have it's sides smoothed.

Smoothing is a lot like splines, it's a curve calculated by 3 points - if you want a tight curve you need three points close together, which is what the extra slices near the corner are for.

Thanks again.

This model was done in all quads, but of course some parts were booleaned to create. All the triangles are the result of triple on all my non planars, which I need to do to fix the shadow errors discussed previously. Most of my edges have small bevels as the tutorial that you pointed out to me as well.

Here is a pic before the triple of non planars and you can see it was quads with the exception of the booleaned areas. This config gives me smoothing and shadow problems which is why the triple.

I guess there is no way to really fix everything?

toby
12-30-2003, 02:42 PM
Yes I realize that you started with quads, what I meant was to model in such a way that you don't end up with non-planars that you have to triple. Boolean can be really sloppy, 'Solid drill' is cleaner.

It looks pretty straight right now, you should be able to make those shapes without getting non-planars - how's the smoothing? try rendering like this and see if the light shows through

kevman3d
12-30-2003, 03:59 PM
Dude,

Smoothing errors are caused by LightWave attempting to shade across all those polys. You need to break the polys, buffer them with extra polys or tweak the smooth settings to clean that up.

Usually the quickest way, specially for mechanical, would just be to select the flat areas, and do the old cut/paste job (but DON'T merge points).

You could also tweak that smoothing angle up and down and see what the effect is.

However, the other way is to buffer by generating extra polys with bevel/knife/etc. Here's an example: