View Full Version : Audio dubbing issue

07-14-2018, 05:28 PM
I fancied having a go with some of my models having a sing song, just to have a go at adding audio...
Problem is I imported 'my way' mp3 by the lovely frank sinatra at 25 FPS and it plays INSANELY slow on the scene editor, at 25 FPS so i cut the frame rate down, even at 7 FPS its still too slow, less than that? then there is nothing at all, I would assume that this audio file is at least 25 FPS, so why is it not playing back properly?!!!??

Its very difficult to find any info on this particular issue
Using LW 2018

Thanks for all help

07-14-2018, 06:17 PM
I'd guess it has to do with the complexity of your scene, causing the playback to be slow. Try Scene Editor=>Load Audio in an empty scene, see if it plays back at speed. You might try the "Play At Exact Rate" in the Options panel, but my (very limited) experience is that it distorts the audio badly.

There are probably a few lipsynch experts out there who may have a workable process, but I'm not one of them! :) It may be that you need to set up a scene where all geometry besides the face / lips / mouth of the singing character are hidden to speed up playback rate, do the lipsynch and then merge it with the full scene.


07-14-2018, 08:20 PM
My only experience doing this was as a student at the DAVE school. (I have the greatest respect for character animators, but would not want to do it for any amount of money, which is why I stick to technical animation in my day job.)

For character voices, we imported our soundtracks into layout (set for 24fps) and used morphs (visemes of phonetic sounds using a mirror to match our mouths with morphs as we created them) to sync the character's mouths to the soundtrack. Very tedious stuff, but it worked great. The soundtrack plays at it's normal rate and the animation is set to 24 fps.


07-18-2018, 11:41 AM
My only experience doing this was as a student at the DAVE school.

Hello fellow DAVE alumn!

I would definitely stick with .wav files as lw seems to handle those better. Also strip your scene down to the only items needed for your animation, then bring them all together in the end. Your scene could be too heavy.

07-21-2018, 01:57 PM
This simply could not be sorted, to my knowledge anyway... The closest I could get was transferring everything to 9.6 where the sound worked just fine, any versions above that? It just played audio insanely slow, and at different speeds every time. Then when you actually attempt to composite them together? Its just a mess.
The total lack of information on this topic is really annoying

07-21-2018, 03:28 PM
Sorry you couldn't get it sorted out. It might be worth a bug report if your same scene works in LW9.6. Through experimenting, I find that in LW2018.0.5, by setting "Play at Exact Rate" on the Options panel (shortcut "o"), that my .WAV file plays well even with 1000 instances in VPR mode using procedural motion, Time Offset, etc. - fairly compute intensive.

Perhaps something in your scene is overriding the "Play at Exact Rate" - genoma? bones? some plug-in? which might be worth reporting.

Good luck!

07-25-2018, 05:13 AM
Most certainly worth reporting... :)


Paul Goodrich
07-26-2018, 12:26 PM
I've complained about this for years. Lightwave's sound support is crap. I can play sound fine in Maya, Modo, Blender and almost anything else I've tried, but not Lightwave. I rigged a single character (Rhiggit) added morphs and a control system. Nothing else in the scene. I could not get the sound to work. 9.6, 10, 2015 (Haven't tried 2018 yet) it didn't matter, nothing worked. With nothing in a scene sometimes the sound played, sometimes not. It would skip and distort and was unusable for animation. I've tried .wav, mp3's at all sample rates and compression settings. After fighting with this for ages I finally couldn't stand it anymore. I spend about a mouth or so figuring out how to get my character out of Lightwave and into Blender to animate and then back to Lightwave to render. It meant learning enough Blender to rig and animate it in, but if you can learn Z Brush you can learn Blender. It's animation tools blow Lightwave's away. So now (it's a pain, I'm afraid) but I model in Modeler or Modo, use Z Brush to detail, Substance to paint, Blender to animate and back to Lightwave to render. Good luck trying to use sound in Lightwave. I wish I had a better answer for you but there's a reason there's not much info around about it.