PDA

View Full Version : New UT2K3 Characters from LW to UnrealED



beramic
12-28-2003, 06:34 PM
Hi,
I don' t know if this is the right place for this thread, but anyway...
I would like to import some new characters into UT2K3. I' ll tell you the tools and process I' m gonna use to do so and then I' ll start with all the questions (a lot of holes in this workflow).
1)Create the model (let's call it Joe) in LW and custom texture/skin it.
2)Export it as an lwo file to Milkshape 3d ver 1.7.0
3)load an UT2K3 skeleton, attach it to Joe.
4)Using the Milkshape converter, export as .PSK file (Joe.psk) to UnrealEd
5)Inside UnrealEd Link it with a standard .PSA file to add standard UT animations and create the package to be imported into the game.

Now here are the questions:
during the passage from LW to MS do I loose the textures?
From Milkshape to UnrealED are the textures transferred correctly (I know it is not LW related, but you guys are good and someone knows)?
It' s OK to use the UT skeletons, but is it possible to edit the animation to change them?

I would like to do the passage from LW directly to UnrealED, but deal with skeletons and animations it' s very difficult. I konw about the plugin from Mike Bristol, but I don' t know if works for UT2K3 and it' s not very well documented (at least for me). Anybody has any experience with it? I would like to avoid using the MayaPLE that comes with the game, I just want to use LW.

Sorry for the long thread, but I' m kind of stuck right now, because I gathered a lot of material from the Web, but the more I find the more I' m confused. Would be nice if someone that did an actual mod for UT2K3 had the time to read this and answer.

Thanks in advance for the help

DraZtiK
12-30-2003, 01:40 PM
http://members.bellatlantic.net/~mbristol/unrealskel/index.html

fortress
12-31-2003, 02:37 PM
bristols plug in is very nice to use once you get used to it

i have used it a lot in the last year there area few bugs to watch out for

one the skelton and model have to be on the same layer i have not gotten it to use seprate layers with out a crash yet.

2 it doesnt seem to like multi objects in a scene sometimes it works other times it crashes.

and number 3 when you setup an ik chain if you use match goal it will not export the motion data correctly

it seems that lightwave processes the plugin before finishing the ik solution so the exporter never gets the last bit of info.

an easy work around for this is to use the constrant motion plugin on whatever bone uses match goal. it will allow you to set up the bone and goal just like match goal so you rig will still act correctly.
but when you add that plugin and turn off match goal lightwave figures out the ik then sends all the data to the exporter.

if you need some help with that just email me and i can send an example scene with a rig setup to export.

beramic
01-05-2004, 08:39 AM
Hi,

does the plugin you are mentioning work with UT2K3 or just with UT?

@Fortress: I sent you a pm, but didn' t get an answer yet. It would be great if you could send me your rigged model to try an export.

Thanks

fortress
01-05-2004, 04:48 PM
it works with ut2k3
thats all i have used it on so far :)

beramic
01-06-2004, 03:10 PM
I have the lW version 7.5.
I loaded the plug in, but somehow I can' t make it work. What am I missing (Now I have a PSK and pSA files I want to import in lightwave, but I' m not very successful)? In case you were wondering I installed the Hub plug in file too.

fortress
01-06-2004, 04:07 PM
did you download the 7+ ver of the plugs if i remeber the hub any everything was included in one plug in that ver

as far as importing them just load them like you whould a normal lwo file if the plugin is installed corrtectly they should open up

beramic
01-07-2004, 10:28 AM
Hi,
I' m sorry to keep bothering you with my problems. I' ve downloaded the 7+ version of the plugin (hub+plugin) and installed following the instructions attached. I can import a PSK file ok, but I see only the mesh and not the skeleton. Furthermore it' s not clear to me what I have to do to export a file in a PSK or PSA format from LW. Is some window supposed to pop up when I try to do so? Thanks again for your help.

fortress
01-07-2004, 12:00 PM
no problem
first question are you importing into modeler or layout
the bring models in differently

next is after you import a model if you take it into layout (or if you imported into layout)
you have to have the model selected and then there is a mbx unreal importer which will import the skeleton and aniamtions froms a pks/psa file set

to export there is a deformation plugin you have to add to the model you want to export it has a pretty easy interface

fortress
01-07-2004, 12:03 PM
http://members.bellatlantic.net/~mbristol/unrealskel/UnrealSkelImport.html

http://members.bellatlantic.net/~mbristol/unrealskel/UnrealSkelPrimer.html

http://members.bellatlantic.net/~mbristol/unrealskel/UnrealSkelConstruction.html

http://members.bellatlantic.net/~mbristol/unrealskel/UnrealSkelMaterial.html

beramic
01-08-2004, 09:05 AM
Hi,
what I do is the following:
Load the model in modeler.
Save it a s a .lwo.
Send it to layout.
Start the import plug in.
Fill the form with the location of the .psk and . psa file, pick the animation and click OK. It works fine, I can see the model, the skeleton and run the animation (btw, can I run the anim showing the mesh and not only the skeleton?).
Now the problem is if I want to export this file to a psk format (just to verify the procedure, the model has not been modified at all). If I fire up the export plug in, the export control form pops up, but is' s completely empty (the model is still on the layout screen, so I assume is selected), there are no file names in the form to check. Which step am I missing?What is this deformation plug in?
Thanks

fortress
01-08-2004, 11:25 AM
ok th eimport is working then one question yousaid the animations plays and the skelton moves but not the model

if that is the case make suer you have the model selected when you inmport the psk and psa file.

also check that all bones are active and are using a wightmap only.

onceall that is good you need to add in the model properties a deformation plugin that will allow the exporter to read all the info from the then the export control panel should list a model to export