View Full Version : Genoma - Items can't be parented to their own descendents

05-20-2018, 06:38 PM
I'm using LW 2018.0.4.

This is the first time I have rigged a model and it's a male figure. I had a model fully rigged with the Genoma Human Biped rig, then sent it to Layout, clicked Setup, then Create Rig. I then got the error, "Items can't be parented to their own descendents."

I did research and what I could find said that this happens when you accidentally delete something or don't select everything when you move. So, I did some experimentation. After a couple times of doing partial rigging, then going to Layout to check, I always got the same error. So, I had one more test in mind.

I renamed the model, deleted the old rig, and added another human biped rig to a new layer. This time I saved the model, then sent it directly to Layout. I did not do anything to the rig, just added it to a new layer. In Layout, I clicked Create Rig and got the same error.

How can that be when I didn't even touch the rig after I had added it? I must be doing something wrong.

05-20-2018, 06:47 PM
Hold off on answering. In the original version of the model I rigged, I copied the rig, cut it, then pasted it into the mesh layer, then saved and went to Layout. That's when I got the error originally. In the subsequent tests, I realized, I had not put the rig in the same layer as the mesh before sending to Layout. That was my mistake.

I will start over with the rig and then get back to you. But, I'm sure it's my mistake.

05-20-2018, 08:05 PM
Everything is going fine since I realized my mistake.

I'm now rigging a little bit at a time, then, cutting and pasting rig into same layer as mesh, saving incrementally, then sending to Layout to check with Create Rig.

05-20-2018, 11:51 PM
Thanks for the updates on the solution. Too often, questions are posted, and no answers are supplied even when the OP figures out the problem. :thumbsup: