View Full Version : Surface 4 pro VS Modeler question

04-23-2018, 03:36 PM
A friend is running lightwave 2018 and was having a problem, so he asked me since I go way back to the old amiga days, and I was honestly stumped. (Granted, I still have the old 9.5 version on windows 7...lol!)

He has a surface 4 pro, and his pen works fine on it in everything else, but he can't draw selection loops in modeler.

It looks like it works fine on his windows 10 desktop, and I suggested he switch the preferences from mouse to tablet on the surface, but that didn't seem to fix it either. I googled and told him to install the wacom wintab driver, but that didn't help either.

Is there some oddball issue using lightwave modeler on a surface 4 pro? I tried searching for him, but searches using "surface" and "pen" just kept turning up modeler surface panel and the pen tool settings.

04-23-2018, 09:45 PM
A (screen) touch device is not the same as an external pen tablet device.
Using a pen on a touch screen makes it even more confusing.
Many times compatibility is obtained by emulating a mouse.
If everything fails, send a feature request.

04-24-2018, 04:23 AM
Yeah, that's a feature request.
With surface, you can't use the pen on the screen for all tasks; the one you've highlighted is the most annoying.

I will try this at work on a surface studio: change a button to the left mouse button.
I think the logic of the surface isn't programmed into lw. That is to say, being aware of all these inputs isn't available to lw.

04-24-2018, 07:02 AM
Wow, I'm kind of shocked by this! I could understand if it was a new device, but I think he got his surface a few years ago. I'll pass on the bad news, and thanks.

04-24-2018, 11:43 AM
Worked perfect under Window 8.1. Windows 10 changed many things with the pen.

04-24-2018, 01:45 PM
I would think at least the touchpad would work, but he said neither the screen and pen or the touchpad worked.

04-24-2018, 04:33 PM
How have they configured the right-click / right-drag functionality for the tablet as well as for the Surface touchpad?

If neither the touchpad nor pen/screen approach are working, chances are there is either something off in LW's configs, or something's interfering with how input events are being handled.

Does right-click-and-drag functionality work in other apps?

If right-click-and-drag functionality is "redefined" or altered somehow at a system level, there's a high probability that would also break lasso selection in LW.

04-24-2018, 04:45 PM
As far as I know he has default settings... I know he has zbrush running on it fine. I was thinking maybe I'll tell him to try compatibility mode for an older windows install.. if win 10 really is the problem, that might should've it at least for his touchpad use.

From what he told me, when he presses and holds the button on the pen, it acts like a right mouse click.. That how he uses it in zbrush, and general windows use.

I would think that would just translate to the same use in lightwave. I was kind of shocked that modelled looks virtually the same as it does on my 9.5...lol!

04-24-2018, 04:51 PM
As far as I know he has default settings... I know he has zbrush running on it fine. I was thinking maybe I'll tell him to try compatibility mode for an older windows install.. if win 10 really is the problem, that might should've it at least for his touchpad use.

Win10 alone doesn't explain both pen/screen AND touchpad being broken in LW. Touchpad should be treated same as mouse, regardless of pen driver and system settings, etc.

That's why they need to verify that RMB click-and-drag functionality still works from touchpad in other apps: If it doesn't, that's an indication something else is messing with the input event stream before LW ever gets a chance to see it. OTOH, if the touchpad works fine for RMB click-and-drag in other apps, that's a pretty solid sign the problem is something to do with LW's configs.

04-24-2018, 06:23 PM
Yeah, everything is working fine on his surface... Only problem he was having was this in modeler. I can't believe no one else has tried to use lightwave on a surface before this though.

04-24-2018, 07:08 PM
I have. My students do it daily.
With your finger and an external keyboard, it all works like the mouse.

The surface stylus doesn't work like I want. I will go through jwiede's thoughts tomorrow to see if I can share something of worth.

04-24-2018, 07:34 PM
I have a Surface 3 Pro, as a matter of fact, but haven't run LW on it for quite a while -- I use it mostly for 2D diagramming and artwork. I do recall I had LW2015.3 running tolerably on it at one point, at least w.r.t. Modeler, but would need to go back and see what settings were needed.

If I get a chance in next week or so, I can install LW2018.0.3 and see whether it behaves differently than 2015.3 w.r.t. N-Trig pen or touchpad.

04-25-2018, 12:26 AM
Not read everything here, but maybe related to Win 10 Creators Update and its change of pen behavior?




04-25-2018, 07:04 AM
Ok, I think I at least found a temp solution for him. He tried the compatibility modes I suggested, and nothing changed the behavior. I was googling about the surface touch screen (My google fu is FAR superior to his.. lol!) and I read that a long press with your finger that is acts like a right click.

He tried that, and while its not as precise as a stylus, it does seem to work if he uses his finger for loop selecting!

I also read some app called radial menu might help, but it seemed a bit unusual, and I don't think he would "get" it easily, so I didn't recommend it. (I was also concerned it would change the normal behavior, and screw up his zbrush.)