PDA

View Full Version : Severe reflection crawlies cannot be eliminated



Mr Rid
04-17-2018, 10:34 PM
I am encountering a showstopping render artifact. I don't know what I might be missing, or if this has been mentioned in other threads.

The attached scene renders with severe reflection crawlies, and I can find no setting that will even reduce them, except to disable Trace Reflection altogether. Hot spots twinkle over the surface of the car, and on the nearby "median" object which is specular but not reflective. Cranking up AA and samples, or changing Polygon Intersection Mode have no effect. The twinkling goes away on the Median if I turn off it's spec.

Anyone else having this problem? In general, I see a lot of noise on surfaces, and am having to crank up Q settings so much to get rid of them that render times are much longer than the equivalent render quality in LW 2015.

madno
04-17-2018, 11:59 PM
Switch off "glossy reflections" on Body and Median material ?
You loose object on object reflection, but in this scene it might be not relevant anyway?

3D Kiwi
04-18-2018, 12:52 AM
Pretty sad if you have to start turning things off just to get render out, surly there must be a way that keeps the reflections?

erikals
04-18-2018, 03:48 AM
might wanna read >
http://forums.newtek.com/showthread.php?156280-Really-NewTek/page4&p=1539007#post1539007

gerry_g
04-18-2018, 07:23 AM
Changed median wall to principled BSDF, the clamping helped stop it attract fireflies, normalised area light added inverse 2 and maxed out range and upped lux to 400000+, smoothing threshold reduced on all surfaces to 34 to get rid of noice i trunk rear end, changed some other things, file attached. Bad lighting, bad geo, too high a smoothing angle, lack of clamping on non BSDF materials, list goes on, been two months and I still get stumped, answers seem no where near as simple as every one seems to make out

madno
04-18-2018, 02:52 PM
Yep,
but as the orig scene is, well, as it is. Switch off glossy refl. is the most easy (read as "don't put more effort (read as: don't invest more than a few thoughts)" way.

gerry_g
04-18-2018, 03:54 PM
metallic values for one rely on glossy reflections being on, if you think turning them off is a panacea for all your ills you are wrong, many other surface settings rely on it too, this is blatant mis information, several surfaces in the example render have glossy reflection turned on yet there are no fireflies, instead of questioning what I am doing ( which is perfectly reasonable in it's self) I think its time to question what you are doing, you are severely limiting what you can achieve by constantly turning them off when what you should be doing is learning how better to deal with your problems.

adk
04-18-2018, 07:12 PM
metallic values for one rely on glossy reflections being on, if you think turning them off is a panacea for all your ills you are wrong, many other surface settings rely on it too, this is blatant mis information, several surfaces in the example render have glossy reflection turned on yet there are no fireflies, instead of questioning what I am doing ( which is perfectly reasonable in it's self) I think its time to question what you are doing, you are severely limiting what you can achieve by constantly turning them off when what you should be doing is learning how better to deal with your problems.

I'm with Gerry on this one. Turning off glossy reflections can't be a blanket solution for this issue. That's like suggesting that the solution to "there's too much red in my image" is "simply make your image black and white" :D

samurai_x
04-19-2018, 10:47 AM
Turning off glossy reflection on some materials makes some renders look like crap.

MonroePoteet
04-19-2018, 12:08 PM
IMO, the "crawlies" or "fireflies" are caused by a bad behavior (bug?) in LW2018 regarding visibility of Lights to the Camera in Specular surfaces. I don't think that LW2018 correctly turns OFF the visibility of Lights when it should.

To make a REALLY long post short: I think until LW observes the "Visible to Camera" setting on ALL Light types, and turns it OFF by default there will be these Specular hotspots causing the Crawlies / Fireflies.

Attached is a sample scene which demonstrates the problem. All light types (Area, Distant, Point, NGon, etc.) except a few produce extreme white highlights in the Specular surfaces even though the Visible to Camera option is OFF in all cases or is supposed to be unimplemented.

IMO, LWDG needs to prohibit these extreme white hotspots in Specular surfaces unless the Visible to Camera option is enabled for Light types which support this option, and should not be visible in Lights where the option isn't available.

141305 Area Light
141306 Distant Light
141307 Environment Light
141300 Linear Light
141301 NGon Light
141302 Point Light
141303 Spherical Light
141304 Spot Light

What do you guys think? I'm reluctant to post a bug on this (even though I think it is one, and a serious one) since it may be "expected behavior" in "physics based rendering". If it *is* expected behavior, I think the only option is to reduce the Specular level to VERY small.

In the Crawlies scene posted originally, the "fireflies" / "crawlies" can only be eliminated (without disabling Glossy Reflections) or brought down to something which might be akin to Reality by taking Specular on the Median object down VERY small, like 0.01% in the Standard panel and 0.1% in the Procedural Texture panel, or less!

Here are various settings of Specular on the Median surface (see the file names for the Specular percentage in the Standard panel and the Procedural texture - the Layer Opacity (center number) is alway 1.0). With the Standard panel set to 0.01% and the Procedural set to 0.1%, there are what might be considered realistic highlights on the Median. But even having the Standard set to 1.0% and the Procedural set to 1.0% produces significant fireflies / crawlies on the Median:

141320

141315 141316 141317
141318 141319 141321
141322 141323


In the Crawlies scene, it seems clear to me that these Specular hotspots propagate through the Specular reflections. For example, if I carefully go through ALL of the Car's Surfaces and remove all Specular, Reflection, Bump and Roughness (including CarPaint's Paint Specular and Flakes), then I get this render (with no fireflies on the Median):

141313

If I ONLY increase the Chrome Surface's Specularity, I get this (with fireflies on the Median):

141314

mTp

141324

P.S. The issue with Roughness or Bump I believe is that any "microfacet" of these surface characteristics may compose a spot for these Specular hotspots to reflect the visible Lights.

Mr Rid
04-19-2018, 07:25 PM
Switch off "glossy reflections" on Body and Median material?

The realistic look of the car surface depends on Glossy Reflections. Turning off GR is sorta like turning off trace reflections as a solution. But that also does not eliminate crawlies on the Median surface.


...file attached. Bad lighting, bad geo, too high a smoothing angle, lack of clamping on non BSDF materials...

Thank you for your time! But when I render your scene, I see the exact same crawlies on the car. Your example render looks different. Geometry is not the issue, since the final car is finely modeled, but it produces the same problem, along with any other car model I swap in. And Smoothing is not the issue since disabling that has no effect either. Your light changes effectively put the light intensity back where it started, and effect no change. Adding Inverse Falloff only lowers the effective intensity, that you then compensate by cranking intensity way up. Falloff is not needed for a "Sun" light. My initial light at 5 lx is the same as a normalized light at 3000 lx. Limiting Dynamic Range under Processing tab also has no effect.

The problem appears to be inherent in the reflection shader.


IMO, the "crawlies" or "fireflies" are caused by a bad behavior (bug?) in LW2018...

Thanks for your thorough evaluation! I do consider this a bug, even if technically the "math" may be correct under the hood. I do not care what the tech explanation is. I am trying to render something very straightforward- carpaint material, one light, and a simple surface with 1% spec. It is odd to me that AA has ZERO effect.

I just started trying to use LW2018 for work. And I violated my personal rule to normally avoid any new version of LW, like v8, v9, v10, because they are too buggy for production. I am not paid to troubleshoot software. I usually wait for significant updates like v9.3, etc, when more kinks are worked out. The problem here is that I have setup assets in 2018 that are not practically backwards transferable to a more reliable version. Offhand, I cannot get the car surface to look as good in LW2015, but the crawlies are non-existent. And the same setup renders much faster without noise.

I ran into other major bugs. PFX crash a scene when I scrub the frame slider, but not in 2018.0.1, so that is a temp workaround. And I lose camera focal envelopes when front projection is present. But this reflection crawly issue is rendering LW2018 unusable, and putting me in a difficult position on a major project.

I will just go ahead and ask here... why dont Moblur Subframes do anything? And I cannot get volumetric lights show in the alpha channel.

madno
04-20-2018, 12:03 AM
@Mr. Rid,
exactly what you and Monroe describe is the reason for the idea to switch off glossy reflections. I also saw that Gerry_G solution still had the fireflies on the car. I normally want reflections (light and objects) to be active, like you. But because of the fireflies and and high rendertimes to get rid of them (if possible at all) in your scene, I would consider to fake the whole thing. Refl. off, refl samples down to 1, etc. putting a light in front of the scene to simulate the refl. on the side of the car and to switch off GI at all etc. GI does not do much for this scene in my opinion - of course if it is only a test and you want to add an environment later than this might be different. But in that case you might also want refl. back on. Again: only according to this scene like posted, the refl. off might be an undesired but working solution. Rendertime on my machine is 1.6 seconds.

141346
Maybe you would need a few more light to fake GI. Or try with the new Env light of 2018

Mr Rid
04-20-2018, 01:16 AM
... is the reason for the idea to switch off glossy reflections...

Thanks for the suggestion. But if you enable Trace Shadows, you should see how Glossy Reflections nicely reflect the road along with the car shadow. Other final road details will also be reflected like white lane lines. So faking an underlight is not nearly the same. And GI on/off is beside the issue. The final scene will have dozens of CG cars that must integrate convincingly into an environment with actual cars with same reflections.

gerry_g
04-20-2018, 03:27 AM
only thing I didn't do was add fresnel to the rear window in my version to give it a sheen and help clamp its reflections, but by far the biggest problems in the scene were the unclamped area light throwing too much light at the rear window, trunk and rear bumper, this was made worse by the overly high smoothing angles on the vehicle itself, some were as high as 180%. If you go the rout of always turning off glossy reflections to solve your problems you will never become a master of the real problems that the new path tracer presents, glossy reflections are an integral look of many surface settings, the trick is to learn how to use them.

madno
04-20-2018, 02:06 PM
Agreed, turn off glossy refl. only if you can live with the loss of visual quality. If you can't, take the render time penality and join the firefly battle.

erikals
04-21-2018, 02:12 AM
you can render out buffers, for compo.

in the reflection layer of the compo in DaVinci Resolve / Fusion you can then use a denoiser.

...a partly-solution

-------------------------

p.s.   i assume you increased the reflection samples?

OjN
04-21-2018, 08:32 AM
Lw2018 render don't like small and point lights. For nice and fast reflections you need big area lights or blured hdr env. maps.
My solution is increase the size of the area light (or use one for diffuse and other more bigger for reflection with a blured map) and use the new Principated shader.
Also, you can blur a baked environment illumination map.
141373
141374

OjN
04-21-2018, 09:13 AM
I recreate the problem and the solution.
In some situations, can be problematic because change the look of the scene.
http://forums.newtek.com/images/BP-Brown/smilies/devil.gif
141378

141375


141376141377

OjN
04-21-2018, 09:38 AM
I attached my last attempt...ummmm
Size is the key factor, lights samples the second (here 256).
I believe use a map for the light may helps...
141379
141380

samurai_x
04-22-2018, 01:15 AM
Agreed, turn off glossy refl. only if you can live with the loss of visual quality. If you can't, take the render time penality and join the firefly battle.

That's not a solution or a workaround. That's a disability :D
Again turning it off makes some renders look crap.

erikals
04-22-2018, 01:25 AM
Ridlen, i guess this is something to bug report...
i see no one at FaceB solved it either > https://www.facebook.com/groups/lightwiki/permalink/1390854257687236/

remember to attach content file

https://i.imgur.com/5jEi2Ve.png

lardbros
04-22-2018, 04:25 AM
Hey David, thanks for posting the demonstration file.

So, to fix the issue here, I selected all of your 'Standard' materials and right-clicked them, did a convert to Principled Nodes, and that seemed to fix it.

My thought is that some of the 'Standard' material chrome shaders were causing overly hot pixels to go flying around the scene and they won't ever clear up.
That's the issue with PBR rendering, if something defies these laws, like the 'Standard' material (which is really only there for backward compatibility) then all hell can break loose!

Try what I suggested, it fixes it here! Good luck!

ianr
04-22-2018, 07:13 AM
That's not a solution or a workaround. That's a disability :D
Again turning it off makes some renders look crap.



We need Auto- ' Defly' , LW3DG & fast!

madno
04-23-2018, 12:59 AM
I would be happy to hear from NewTek at all.

Do they consider fireflies to be an issue or do they think its all about the settings like Gerry_G says?
Or something in between?

Maybe somebody who sent a bug report regarding fireflies got a feedback?

erikals
04-23-2018, 01:47 AM
http://forums.newtek.com/images/misc/quote_icon.pnglardbros
So, to fix the issue here, I selected all of your 'Standard' materials and right-clicked them, did a convert to Principled Nodes, and that seemed to fix it.

hopefully this is the solution.
...also remember to have high reflection samples

jwiede
04-23-2018, 06:39 AM
hopefully this is the solution.
...also remember to have high reflection samples

"Don't use Standard materials" isn't really a "solution" any more than "Turn off glossy reflection" is one.

If Standard materials are broken, they need to be fixed.

gerry_g
04-23-2018, 08:13 AM
no they just need to be clamped, fresnel for instance, have many setups with standard materials and see no greater problem than with any other type, and by any other type I mean carpaint, conductor, delta, dielectic, only BSDF seem to have the fresnel function baked in and I suppose that is why it seem to work better than standard, besides surface is not only cause of fireflies , lighting values can contribute, quality of mesh (planarity) can be another

erikals
04-23-2018, 04:54 PM
so, 'bit more info at...
https://www.facebook.com/groups/lightwiki/permalink/1390854257687236

lardbros
04-27-2018, 06:22 AM
"Don't use Standard materials" isn't really a "solution" any more than "Turn off glossy reflection" is one.

If Standard materials are broken, they need to be fixed.

Standard materials aren't broken as such, they just aren't energy conserving by themselves. You need to "engineer" them manually to be so.
They are more there for non photoreal stuff, and for compatibility with I/O. Think of 3dsmax and its standard phong shader, it is there for compatibility when you export to game engines etc.
Try rendering those materials in Arnold, and it'll do its best but they'll look wrong.