View Full Version : Problems with bullet and cloth in 2018

04-17-2018, 05:10 PM
Guys, I was trying a simple cloth simulation using bullet in 2018.3 and had a bunch of issues. Then I tried the old Cloth_Covering_Car sample scene in 11.5 content (Bullet_Dynamics/Cloth Dynamics/Car_Covering_Cloth/Scenes) for a sanity check, and it wouldn't work either (works fine in 11.5). Is there something different in 2018 for bullet and deform?

04-18-2018, 08:25 AM
Interesting. I loaded the Cloth_Covering_Car into LW2018.0.3 (having it converted into a "safe" folder). Initially, the simulation didn't work, but all I did was get into Modeler, load the Cloth object, press the Synchronize Layout button, and suddenly it works. Once I use Save All to save everything, future loads of the scene work.

If you see the same behavior, it's probably worth a bug report - something in the import-from-prior-versions code isn't setting up the Cloth object correctly, while Modeler is able to fix it.


04-18-2018, 01:09 PM
Thanks, yeah it seems to suddenly work for no apparent reason (I think it started working for me when I did something else, don't remember what). Also, the problem with my model turned out to be related to scale: apparently bullet works correctly only when the objects aren't too big (the 2018 docs do mention this). After reducing the size and following other directions in the doc (like giving the cloth thickness, etc.), the cloth worked right away. Here's the model and the render with the simulation - FYI, I created this for a matchmaking site with machine learning (matchtowed.com (http://matchtowed.com)) that I'm launching.