PDA

View Full Version : Layout 2018.0.3 Normal map bake error?



spunkyfl
04-10-2018, 05:42 PM
Hey there!

Recently upgraded to 2018 and have been giving it a run-through of a multitude of tasks and stumbled upon a very frustrating issue. I'm still not 100% sure if it's user error or a software bug so here I am in hopes of figuring this out.

This should be a very straight-forward normal map procedure. I've got a high-poly cube that is to be normal mapped onto the low-poly cube. The issue I'm having deals with the rounded corners interpolating very strangely to the normal map.

Here is the low poly cube - straight forward with beveled edges
141135

This is what the high-poly consists of -
141136

This is the normal map it spits out -
141137

This is a render of the low-poly cube with normal map applied and x-channel inverted (edges invert along with right side of cube) -
141138

Here is the render with no x-invert (All sides are correct but corners are now bulbous?)-
141139

Also I noticed the way the cage gets drawn when the surface bake camera is selected is really funky, not like the usual cage outline? -
141140

Current surface bake camera settings, I've tried everything from 1mm offset to 200mm offset, doesn't resolve the rounded corner issue (currently set to 60mm in test scene) -
141141

Here are some things I've tried -


I've tried having the low-poly be exactly the same size as the high-poly (which is is right now in the test scene), along with it being ever so slightly smaller or larger... just to see how it affects these edges.
I've played around with the surface bake camera distance as well and that seems to not solve the issue with these corners.
Tried with both smoothing on / off
Double sided on/off doesn't seem to affect outcome
Also tried baking to a low-poly cube with no beveled edges, same outcome


I've baked my fair share of normal maps and haven't ran into this issue in the past, so if someone wouldn't mind taking a look at this scene and seeing if you can get a correct bake out of this I would be ever so grateful!

Test scene download here (forum wouldn't let me upload .zip directly?) - https://www.dropbox.com/s/h1y8c390pxfdegk/NormalMapBakeTest.zip?dl=0

Cheers!

spunkyfl
04-10-2018, 11:53 PM
UPDATE :

Figured I would emulate this scene in LW 2015.3 to see if I ran into the same problem. I knew surfaces etc. wouldn't translate back to 2015 but I was bummed to find out that I couldn't even open the objects and/or scenes at all. When I try to load either LW2018 pops up with an error saying a cyWig module is missing or something, no way around it and I didn't feel like exporting out as fbx and re-importing to 2015, so I just quickly remade another cube to test it.

This is the result I got from 2015.3 using DP kit Normal Cast node to bake the normal. It's not perfect by any means but is definitely a lot more accurate on rounded corners than what I was able to drum up in LW2018. There are some dark edges but that would be taken care of post-bake by tweaking the uv's in a smidge.

High poly on left - Low poly w/ Normal map on right

141145

Would still very much appreciate this to work in LW2018 so if anyone has any ideas I'm all ears.

Thanks!

MarcusM
04-11-2018, 12:44 AM
Hi,

Sorry to say but from my experience baking normal map in LW is waste of time. In Substance Painter you will get perfect normal map in seconds. You can try also in free xNormal.

141147

141148