PDA

View Full Version : LightWave 2018 Depth Buffer issue



IsraTan
04-01-2018, 01:55 AM
Hi,

I知 trying to get the Depth pass in LightWave 2018, but I知 getting a white image, even VPR Depth shows the same result.
I have tested the same scene in LightWave 11 and it works fine.

I知 wondering if I知 missing something.
I checked and tested the solution provided in this section of the documentation (https://docs.lightwave3d.com/display/LW2018/Buffer+Appearance), however did not work.

Any suggestions/ideas will be highly appreciated?

Thanks

CaptainMarlowe
04-01-2018, 03:46 AM
For your depth buffer to appear correctly in VPR, you have to "normalise buffers" in VPR options. In image render viewer, the depth buffer final render shows as white, but when saved, it appears with the right informations. You can check the final result in the image viewer by ticking the small "n" button, which will normalise display.

140972

MonroePoteet
04-01-2018, 07:59 AM
To add to CaptainMarlowe's excellent response: You have to specify an appropriate minimum and maximum Depth values in the Depth Buffer's render panel. If you leave it at the default (1Mm - 1 Megameter!), you'll just get black for anything even remotely close in the scene.

140976

BTW, I changed the DOF envelope to clear up the image for my testing.

mTp

IsraTan
04-01-2018, 11:01 AM
Hi CaptainMarlowe and MonroePoteet,

Thank you so much for your suggestions.
It is working now! As you mentioned, doing both things solves the problem.

Thanks again.

VirtualFM
03-11-2019, 02:09 AM
Wow!

This answer saved my day.
Now I just wish I didn't spend the last 3 hours looking for a solution to why the Depth Buffer was not working no matter how big or small values I entered on the Near/Far fields! I was one step away to go back to the old trick of using Linear Fog with black matte objects!

Some note regarding this should be helpful in the manual, near the depth buffer options.