PDA

View Full Version : Problems over problems and such a weak documentation



KANUSO
03-30-2018, 02:12 PM
I get more and more frustrated. Even the easyest things went wrong.

Can anybody give me an example of how to use "move" in lwsdk.pris

The module is initialized and all had functioned well... but move...

if I do



movv=lwsdk.Vector(1.0,1.0,1.0)
mcmd.move(movv)

the Console Pops up and says:
File "D:\NewTek\LightWave_2018.0.2\bin\lwsdk\pris\modele r\__init__.py", line 2466, in move
return _move_code("MOVE", offset, arg2, arg3)
File "D:\NewTek\LightWave_2018.0.2\bin\lwsdk\pris\modele r\__init__.py", line 2440, in _move_code
elif isinstance(offset, (lwsdk.Vector, list, typle)):
NameError: global name 'typle' is not defined


using the same Vector with:
mcmd.rotate(45,"X",movv)
all goes well, so it seems the vector is right.

and if i feed the move directly:


mcmd.move(1.0,1.0,1.0)


I will get the following Error:
140939

even if I say



mcmd.move(float(1.0),float(1.0),float(1.0))


I get the error

Can anybody please help me out

I am so frustrated about that Situation. Every Information must be searched bit by bit in hours and hours.

Please help

Regards,
KANUSO

KANUSO
03-31-2018, 01:46 AM
After hours of try and error, hours of searching for Information in the Internet, I thought that it is enough and changed the line with the error in the __init__.py for the pris/modeler

here what I did:
the original line (2440):
elif isinstance(offset, (lwsdk.Vector, list, typle)):
which is in fact wrong !!!
I changed it to:
elif isinstance(offset, (lwsdk.Vector, list, tuple)):

I changed from "typle" to "tuple" and all is going right now. I will use the Feedback Assistent to inform NT about this error

Regards,
KANUSO