PDA

View Full Version : 2018.0.2 (build 3065): Tweak tool broken?



rsfd
03-02-2018, 10:22 AM
Hello everyone,

with the new build freshly installed, I'm noticing erratic behaviour of the "Tweak Tool":

- Edges will not be selected at all
- Points are barely selectable
- free moving of elements (Points or Polygons) leads to uncontrollable results

Only Shift-moving (constraint to Normal) does work both with LMB and RMB.

This is on OSX 10.11.6. Complete fresh installment of LW (all old versions, Prefs and Configs were removed prior to installation).
It did work with 2018.0.0 and .1

Anybody can confirm?

jwiede
03-13-2018, 02:35 PM
Not seeing same problem here (2018.0.2 demo, OSX 10.13.3), able to select edges, points, etc. without difficulty and slide them around. Are you using mouse or tablet to control?

gerry_g
03-13-2018, 03:42 PM
I find your comment hard to justify, I can only select in orthogonal view which means that ninety nine percent of the time it is impossible to select an edge if the object is 3D as very few edges are not stacked on top of themselves, moreover if I try to select in the perspective viewport the selection extrudes to my curser position which the program is readings as being entirely somewhere else in Z space to the actual selections position. Oh wait a minute I'm using a tablet, they've only been around for twenty years, it a tad premature to expect all computer programs to have caught up with them.

2create
03-13-2018, 04:16 PM
I'm having the same issue with "Part Move" and "Transform" tools.


https://www.youtube.com/watch?v=Gtm-RK2_mZ4

This video shows edge and points selection working well in 2018.0.1 then it unable to select edges and rarely points in 2018.0.2

rsfd
03-13-2018, 06:41 PM
@ jwiede
the issue happens equally both in Mouse and Tablet mode.

@ gerry_g
That describes precisely what I’m experiencing here.
Nonetheless, Edge selection is 100% impossible.
Points very, very rarely (seems somewhat angle related).
In orthographic viewports, the tool does work even in „free” mode, but exclusively on polygons.
In the perspective viewport -where the Tweak Tool would be very handy- „free” tweaks lead to heavily exaggerated polygon extrusions into the „user’s direction”, what makes this tool actually completely useless right now.


@ 2create
the issue with the Transform Tool is confirmed in this thread:
http://forums.newtek.com/showthread.php?156344-Transform-Tool-2018-02

it is reported and -hopefully- every tool is fixed in the next build…

Chris S. (Fez)
03-13-2018, 06:56 PM
Confirmed here on Windows. Can no longer Tweak in perspective view screen space.

jwiede
03-13-2018, 09:39 PM
Confirmed here on Windows. Can no longer Tweak in perspective view screen space.

Ah, I didn't realize perspective screen space was where the problem existed, and instead tried in one of the orthogonal views, where tweak works fine.

In perspective view, I can confirm, I cannot get tweak tool to select edges at all, and getting it to select points is quite tricky/difficult, as noted.

Chris S. (Fez)
03-14-2018, 12:46 PM
Something is up. Align Axis tools...which are great btw...are inconsistently snapping to points and other elements in perspective view.

jwiede
03-19-2018, 10:01 PM
Hmm, interesting. So are all the LW11 "New Tools" affected in similar manners in perspective view (and specifically just them)?

Chris S. (Fez)
03-20-2018, 08:05 AM
Seems so. But they are all fixed for the next patch.