PDA

View Full Version : Lightwave 7.5 (and 7.5b) buglist/feature request



mlinde
03-07-2003, 02:54 PM
The title says it all. Post here if you find a bug you can duplicate, or have a feature you want added, and maybe Chuck et.al. will read them. The old 7.5 buglist (which Chuck ported to this list) was extremely useful to NewTek when working on 7.5b, and LW[8] will come eventually, with more features and more fixes.

001 (7.5/7.5b)
Hub functionality is non-existent, beyond erratic get/put functions. No automatic shutdown, no automatic save. Get/Put functions between Layout and Modeler do not consistently function. No upgrade with 7.5b.

riki
03-07-2003, 05:02 PM
002 (7.5b OS9.2)

The Surface Editor disappears beneath the main window when you click to open the Preset Shelf. This makes it difficult to know which surface you working with or to switch quickly back and forth between the two panels.

003

The Numeric Panel disappears when you click in one of the Viewports. This makes it hard to switch back and forth between the two when your trying to make adjustments.

004

I'm getting this intermittent 8 bit cycling effect. It appeared shortly after I installed the 7.5b update.

Kuzey
03-07-2003, 05:41 PM
The "JPEG.p" Plugin hasn't been fixed....delete it if lightwave crashes when trying to import .jpg's.

Otherwise, it's working superbly....so far :p

Kuzey

JDaniel
03-07-2003, 06:54 PM
Is it possible to add incident angles to the input parameters of gradients in mesh displacements?
And a shader that calculates the differance between the surface normals(Arnie's rgbnormal.ls), of 2 objects ,(hi/lo res)in the same space, and creates a displacement map for lo res mesh on uv map.:D PLEASE! I know LW has the power.

roberthurt
03-08-2003, 02:33 AM
I'm having some severe lighting problems with most of my 7.5 scenes; I've got more details posted in another thread (http://vbulletin.newtek.com/showthread.php?s=&threadid=1564) .

LeeK
03-08-2003, 12:16 PM
I have LW installed on 2 hard drives (1-OS 9 and 1-OS X), I have done the upgrade to the Os 9 one and seen the above bugs.
Before I do the same to my LW on OsX drive, does anyone know if these bugs are Os9 apparent only???

barnabythebear
03-08-2003, 01:31 PM
HI,

Layout in OSX.2.4 crashes on quit. Even though I save any keyboard shortcts and menu changes they do not keep when I re-launch, I guess due to the crashes?


nige. :(

barnabythebear
03-08-2003, 04:23 PM
Well..... I installed v7 off the disc, then 7.5 and then 7.5b all in a new location and this seems to have solved my problem. Sometimes I hate LW, I'm no propellerhead Newtek, please make this app more user friendly!


nige.

riki
03-09-2003, 01:59 AM
I can't zoom in on an object in Modeler. I get so close and then it seems to warp into outer space. Then the perspective starts to freakout and I can't zoom out again. It feels like a scene from the Matrix :-(

riki
03-09-2003, 02:11 AM
I'm now able to Load TrueType Fonts in Modeler 7.5b on Mac OS9.2. But Modeler no longer recogonise my old Type 1 Fonts. When I try to load the Type1 Fonts that I was using before in 7.5. I get an error message telling that this is not a Type1 Font. This is despite the fact that the font is clearly labelled as a Type 1 Font and previously loaded without a problem into 7.5

riki
03-09-2003, 06:34 AM
The Font List isn't being saved. When you relaunch you have to keep reloading the Font List.


L'scripts that worked in 75. but no longer seem work in 7.5b

Align To Rail: http://www.flay.com/GetDetail.CFM?ID=1253
Basic Lofting: http://www.flay.com/getdetail.cfm?ID=1334
CPlane http://www.flay.com/GetDetail.cfm?ID=1535
Depatcher http://www.flay.com/GetDetail.CFM?ID=1374
Incremental Savers http://www.flay.com/GetDetail.cfm?ID=1475
KAG Spline Objects http://www.flay.com/getdetail.cfm?ID=1219
Lathe Curves http://www.flay.com/getdetail.cfm?ID=1362
Quicksaw http://www.flay.com/GetDetail.cfm?ID=1629
Poz Extender http://www.flay.com/GetDetail.cfm?ID=1610

Chuck
03-09-2003, 07:58 AM
Hi, Riki!

LScript 2.6 includes many behavioral changes that will require pre-existing scripts to be modified in order work under the new interpreter and compiler. The behavioral changes are described in detail in the LScript 2.6 change notes at the link provided in the 7.5b readme.

Hmmmm. Actually, that link is broken. Those docs are supposed to be on the Developer page, but I note the web team does not have them posted yet. I'm sure they'll get to that shortly, and in the meantime, Bob Hood has put them up on LightWave Outpost:

http://www.lightwave-outpost.com/Bob/LScript/v26.html

riki
03-09-2003, 08:31 AM
Thanks Chuck QTTools also isn't working I can't load this plugin.

mlinde
03-09-2003, 04:45 PM
005 (7.5b OS 10.2.4)
Scene files are not 100% cross-platform. Image savers, output directories, particles, and other external links do not use the cross-platform directory structure that is used by objects and images. This does not apply to 3rd party plug-ins (which are the responsiblity of the developer), but the built-in systems in LW itself.

OnePerson
05-18-2003, 10:57 PM
:confused:

Unable to load EPS illustrator files?!

I have been using LW since version 7.0 on OS X. 10.5 to 10.2.6 and 7.5c. In version 7.0 I was able to import EPS files saved from Illustrator, eps file type: v. 6.0, 8 bit RGB Color.

However, in LW 7.5c everytime I try to import from an EPS file Modeler crashes.

I have tried trashing my prefs but that doesn't work.

Other issue is that font lists are not saved. This font thing is a real pain to scroll through. I thought I had a good solution by saving my font list but that doesn't work. I tried that because I couldn't import from Illustrator.

Even though I've not be doing this for a long time, I am trying to make a few extra $ on the side. This is very frustrating to say the least.

Anyone with good suggestions, please let me know how to resolve these issues.

Thanks,

loebek
05-19-2003, 03:40 AM
NT should set up an Bug Tracking System.
This will help ALOT!!!
LW wil develop rapidly. OF course only NT is taking bugzilla seriously.
http://www.bugzilla.org/


like:
http://bugzilla.mozilla.org/

loebek