View Full Version : A sudden LW15.3 issue

Andy Webb
02-13-2018, 04:07 AM
I've just been working on a couple of scenes for a client in LW15.3 and noticed this error when I load them in:-

"Can't find specified server"

I tried loading the scenes into LW2018 and no error.

The scenes load and render OK, it's just bugging me as to what might cause it.

It seems to be on every scene I load in now, has anyone any idea what it could be?


02-13-2018, 04:53 AM
Many old servers (plugin handler class, nodes, shaders, image and pixel filters) have been removed in LW 2018.x
Try running Filemon (or similar utility for monitoring disk activity),
maybe it'll show up as file with .p extension, which can't be found.

It could be shader (LWSHADER_HCLASS).

Try loading the all .lwo objects in scene which is showing it, each alone in LW 2018.0.1.
If there will be error message, you will know it's caused by some plugin handler (node, shader, image filter attached to some image).

Otherwise open .lws in text editor,
and try searching for "Server" keyword.
It could f.e. Spot Info node used inside of Displacement or Motion Node Editor or some Compound node.

Andy Webb
02-13-2018, 05:12 AM
After saving an empty scene and clearing different Master Plugins, I found that the error is caused by Auto Render Saver!

Any thoughts, I'll try reinstalling and see if that solves it. I've used it for years but I can remember having this issue once before...

Andy Webb
02-13-2018, 05:26 AM
Re-downloaded Auto Render Saver and re-installed it but still the same problem...

02-13-2018, 05:46 AM
I see where might be problem..
When there is executed command
"RemoveServer ImageFilterHandler [index]"
"RemoveServer ImageFilterHandler 1"
But server has been removed,
LW is showing message "Can't find specified server".

Andy Webb
02-13-2018, 05:52 AM
So is that a problem?

I checked and the saver still works...

02-13-2018, 06:31 AM
Download plugin version 2.2, and check whether message is still appearing or not for couple days.

Andy Webb
02-13-2018, 08:03 AM
Hi Sensei, that worked a treat, thank you very much for sorting it.

Just puzzled as to why the problem suddenly appeared, unless I just never noticed it. :D

02-13-2018, 08:17 AM
Just puzzled as to why the problem suddenly appeared, unless I just never noticed it. :D

Bug. Now is dead.