PDA

View Full Version : 2018 VPR speed



gar26lw
01-10-2018, 01:47 AM
Its too slow.

VPR really needs something done to it to get back the speed!

Please could you make it a priority to kick the speed up with the next point release.

Sensei
01-10-2018, 02:05 AM
Draft mode on, Half resolution on...
For a start..

There is no separate renderer for final renders and different for previews now.

gar26lw
01-10-2018, 02:40 AM
half res makes it hard to see what’s going on. draft doesn’t add much to speed.

i feel like it’s back to the days of pre fprime when it’s test renders for everything.

Sensei
01-10-2018, 02:56 AM
See Input node, it's full of parameters that user can use in Node Editor.
They are calculated regardless of whether user might need them or not.
It contributes to lower speed.

tyrot
01-10-2018, 03:34 AM
installing octane may help :)

gar26lw
01-10-2018, 03:42 AM
unfortunately i have just upgraded to 2018 and.... I’m in modo to get things done, which sucks. :/

jakuzaa
01-10-2018, 03:48 AM
Monte Carlo Brute Force, 1 Ray works fine for me.

prometheus
01-10-2018, 09:56 AM
Monte Carlo Brute Force, 1 Ray works fine for me.

Using vpr draft...
simple ground plane, one box, one sphere, principled BSDF, GI brute force, rays 1 equals 8.27 seconds, while the same scen with 10 rays yields
3,52 seconds ??


I thought it should be slower not faster with more GI rays, on a simple scene like this, the noise is refined much faster with higher ray settings...odd.
Note..this seems be an issue with ray settings at one, when I raise to two rays..it reaches around 3.54 seconds, but a setting of 10 seem fastest, going over to 20 rays, it becomes more slower.

for more dense scenes, I really do not see any difference between draft mode on and off, that is what bugs me with VPR in draft mode.
Using half resolution I never used before in lightwave 2015 since it was quite fast anyway..and the half resolution was just giving a too blury low resolution that I had no good use of.

- - - Updated - - -


unfortunately i have just upgraded to 2018 and.... I’m in modo to get things done, which sucks. :/

elaborate please, what tasks specificly do you find annoying? if you are so kind to enlighten us.

Sensei
01-10-2018, 10:05 AM
Always attach scene, so we will be able to load, and confirm, check, and send to bug report, if multiple people will confirm it..

prometheus
01-10-2018, 10:16 AM
Always attach scene, so we will be able to load, and confirm, check, and send to bug report, if multiple people will confirm it..

of course...
Itīs 10 rays here, making vpr update faster, change that to 1 ray in the GI tab and check vpr render statistics of the bottom of lightwave panels, rendertime should increase if you set it to 1 ray.

My render stats 3,59 sec with 10 rays..
My render stats 8,19 sec with 1 ray.

Note...this was testing using draft mode, but unchecking draft and if you use the fine mode, this is not the case, and the 10 rays is actually slower than 1 ray.

Sensei
01-10-2018, 10:34 AM
I know what is the problem.
Camera settings adaptive anti-aliasing..
It's sending much more rays to get ride of noise..

After clicking in Camera Properties,
turning off Adaptive Sampling,
Brute-Force GI started to render @ 1.41 sec instead of 12.31 sec, here.. straight away..

Simply 10 rays gives less noise than 1 rays,
but Adaptive AA will be trying to care of noise (even if there is just 1 rays),
giving much longer render time.

MichaelT
01-10-2018, 10:52 AM
Its too slow.

VPR really needs something done to it to get back the speed!

Please could you make it a priority to kick the speed up with the next point release.

You have a suggestion tool in the help menu, you need to use that. This why they keep reminding all of us to use those tools in the menu. They won't act on anything posted here in the forums as I understand it. Or more to the point, there will be no tickets in their to do lists otherwise :)

That being said, what do you mean by speed? I can get it it to go quite fast. But some things in the scene can make it slow. Like volumetrics and stuff. So you can open scene editor and disable some objects, and hopefully find out what makes it slow, and go from there. So you can dig deeper and perhaps find or tweak the one thing that affects your scene the most in VPR.

BeeVee
01-10-2018, 10:53 AM
Draft mode doesn't care about your settings. It uses its own, same as it did in 2015: https://docs.lightwave3d.com/display/LW2018/VPR+Draft+Mode+Limitations

B

prometheus
01-10-2018, 10:59 AM
Draft mode doesn't care about your settings. It uses its own, same as it did in 2015: https://docs.lightwave3d.com/display/LW2018/VPR+Draft+Mode+Limitations

B

Dont think you are right about that, and that seem to be a faulty statement from you, if it doesnīt care about my settings, how come I get a faster vpr render with 10 rays?
compared to if I set it to 1 ray which gives a much slower vpr render?
Or do you misunderstand what I have talked about?

BeeVee
01-10-2018, 11:14 AM
Did you look at the page I linked? Those are the draft settings, and if you find that's not the case, then it is a bug to be reported! :)

B

Sensei
01-10-2018, 11:17 AM
Draft mode doesn't care about your settings.

Set Brute Force GI, Draft mode, use 1 rays, see render time in status bottom bar (1.33 sec),
then set 100 rays (11.24 sec)..
(when adaptive AA is off)

So it does care the settings we're talking about.

MichaelT
01-10-2018, 11:18 AM
If you go into render properties->Global illumination and disable (untick) Sample Backdrop. It will speed things up quite a bit.
And if you absolutely need it. add and env light, and set MIS to 6. Not as fast of course.. but faster than the alternative.

Sensei
01-10-2018, 11:26 AM
If you go into render properties->Global illumination and disable (untick) Sample Backdrop. It will speed things up quite a bit.
And if you absolutely need it. add and env light, and set MIS to 6. Not as fast of course.. but faster than the alternative.

Sample Backdrop gives less than 5%.
After turning off adaptive AA, in Camera Properties, there is 300% speed up in refreshing, while using Brute-Force GI (going from 10 GI rays, to 1 GI ray). Even 3 GI rays looked ok, for preview.

Adaptive AA is changing it non-linearly.

prometheus
01-10-2018, 11:26 AM
Did you look at the page I linked? Those are the draft settings, and if you find that's not the case, then it is a bug to be reported! :)

B

Yes..I looked at the page...the file is uploaded here, If I get the time I will bug report.
AS for 2015, the render speed with GI seem to be the same in VPR, regardless how I tweak the GI settings and rays per evaluation, though the VPR rendered image differs in quality and looks.
But as I said, for lw 2018 it differs in speed..and not only Little...But big time.
Anyone else try the scene please and confirm it as a bug?

MichaelT
01-10-2018, 11:31 AM
Sample Backdrop gives less than 5%.
After turning off adaptive AA, in Camera Properties, there is 300% speed up in refreshing, while using Brute-Force GI (going from 10 GI rays, to 1 GI ray). Even 3 GI rays looked ok, for preview.

Adaptive AA is changing it non-linearly.

5%.. then you have other things going on in the scene. But yes.. AA will affect things too. After all VPR & the renderer (as I undertstand it) is the same renderer.

Sensei
01-10-2018, 11:32 AM
5%.. then you have other things going on in the scene.

I am talking about scene Prometheus provided. 5-10% difference after turning on/off Sample Backdrop.

MichaelT
01-10-2018, 11:37 AM
I am talking about scene Prometheus provided. 5-10% difference after turning on/off Sample Backdrop.

Ok tried, that scene.. and unticked sample backdrop. And for me the updates are now near instant for me at least. I don't know why your don't get that kind of speed up?
But I'll try different things anyway.

prometheus
01-10-2018, 11:44 AM
Ok tried, that scene.. and unticked sample backdrop. And for me the updates are now near instant for me at least. I don't know why your don't get that kind of speed up?
But I'll try different things anyway.

instant is within a range of? 0-0
Impossible, provide sec stats please. :) I know the refresh can feel that way..but vpr statistics shows the final speed.
not sure what you mean about speed up, the question was about 1 ray yielding much slower VPR In draft mode finished render at around 8 secs, VS 10 rays ..which yields 3,53 seconds ..something like that, so it was about why 1 ray is slower than 10 rays, and when going over 10 rays, it goes back to slower, and when you go over 1 to 2 rays ..it becomes faster than 1 ray as well, very inconsistent in behavior.



I know I can untick various settings as sample backdrop to make it faster, and cam settings etc, but instant tells nothing...check ray statistics at the bottom of the object/lights/camera panel

MichaelT
01-10-2018, 11:49 AM
I mean in figurative way.. not literal. If the previous setting takes a few seconds to get a coherent image (again for me) disabling the backdrop sampling.. makes the VPR stabilize in roughly 1 seconds. Compared to 5-6 seconds previously. So I'd say that is significantly more than 5%. More like 500%.

prometheus
01-10-2018, 11:57 AM
I mean in figurative way.. not literal. If the previous setting takes a few seconds to get a coherent image (again for me) disabling the backdrop sampling.. makes the VPR stabilize in roughly 1 seconds. Compared to 5-6 seconds previously. So I'd say that is significantly more than 5%. More like 500%.

Hehe..Yah, I got in aspbergers mode I think, you know if you ask me if I can open a window, in a begging way as if you want me to open it..I may take it as a question if I am capable of opening a window, and disregard your request for me to open it :)
I am Cat tired now, so I need to hit the sack now..will check more about this tomorrow, should we file this as a bug..the cases that VPR in draft mode yields various rendertimes when setting different GI ray values, and the fact that 10 rays is faster than 1 ray?

Thatīs perhaps what we need to define (at least for my specific question in this thread), not how fast we can get it ..that is all good in itīs own way..for the rest of the thread, but the fact that 10 rays yields faster render than 1 baffles me.

MichaelT
01-10-2018, 12:01 PM
Hehe..Yah, I got in aspbergers mode I think, you know if you ask me if I can open a window, in a begging way as if you want me to open it..I may take it as a question if I am capable of opening a window, and disregard your request for me to open it :)
I am Cat tired now, so I need to hit the sack now..will check more about this tomorrow, should we file this as a bug..the cases that VPR in draft mode yields various rendertimes when setting different GI ray values, and the fact that 10 rays is faster than 1 ray?

Thatīs perhaps what we need to define (at least for my specific question in this thread), not how fast we can get it ..that is all good in itīs own way..for the rest of the thread, but the fact that 10 rays yields faster render than 1 baffles me.

Not necessarily. Because we have no idea how the engine is set up. If you have 1 ray on a 16 core CPU. then having less than 16 is probably ineffective. As that would cause a wait (I'd imagine) So try setting it to the number of cores (not logical cores) in your CPU.

I set mine to 8, and now it finished in less than 0.5 seconds.

Edit: The reason why I mention raw cores, not logical. Is because you already have processes in the CPU in the engine. So adding logical is probably stalling on the other end of things :) But try it yourself.

Chris S. (Fez)
01-10-2018, 12:05 PM
Pretty easy fix. Makes a difference on my system as well.
NewTek should update the core Draft Mode code to include these "optimizations" immediately so it makes it into the 1st patch. Will make a good impression.

Sensei
01-10-2018, 01:24 PM
Pretty easy fix. Makes a difference on my system as well.
NewTek should update the core Draft Mode code to include these "optimizations" immediately so it makes it into the 1st patch. Will make a good impression.

I made feature request already to expose Rendering presets in the front Layout panel, above VPR..
You go to Render Globals, click on top drop-down open Shelf Preset.
Add full preset to shelf preset.
Then disable everything to the smallest settings,
and add quick preset to shelf preset.
Now you can toggle between them using Shelf Preset window.
But I wanted to add drop-down to pick them up more quickly.
There is no need to have "draft mode" toggle. Just drop-down with the list of user made rendering presets..

jboudreau
01-10-2018, 09:17 PM
Yes..I looked at the page...the file is uploaded here, If I get the time I will bug report.
AS for 2015, the render speed with GI seem to be the same in VPR, regardless how I tweak the GI settings and rays per evaluation, though the VPR rendered image differs in quality and looks.
But as I said, for lw 2018 it differs in speed..and not only Little...But big time.
Anyone else try the scene please and confirm it as a bug?

I tested your scene, Something is definitely weird about this. Like you pointed out 1 Ray should be faster than 10 Rays but it's not. Also look 1 Ray in Draft mode was slower than 1 Ray in Full Mode that doesn't seem right to me, very strange

VPR Draft Mode

with 1 Ray = 17.30 Seconds
with 10 Rays = 6.20 Seconds
with 20 Rays = 8.50 Seconds


VPR Full Mode (No Draft Mode)

with 1 Ray = 13.80 Seconds
with 10 Rays = 33.31 Seconds
with 20 Raysy = 48.65 Seconds

Now if you use interpolated mode 1 ray will not render faster than 10 rays, it works like it should

This is also interesting if you turn off the gradient backdrop in your scene then it now takes longer to render 10 rays compared to 1 ray like it should

Hope this helps

Thanks,
Jason

MichaelT
01-11-2018, 12:08 AM
I tested your scene, Something is definitely weird about this. Like you pointed out 1 Ray should be faster than 10 Rays but it's not. Also look 1 Ray in Draft mode was slower than 1 Ray in Full Mode that doesn't seem right to me, very strange

VPR Draft Mode

with 1 Ray = 17.30 Seconds
with 10 Rays = 6.20 Seconds
with 20 Rays = 8.50 Seconds


VPR Full Mode (No Draft Mode)

with 1 Ray = 13.80 Seconds
with 10 Rays = 33.31 Seconds
with 20 Raysy = 48.65 Seconds

Now if you use interpolated mode 1 ray will not render faster than 10 rays, it works like it should

This is also interesting if you turn off the gradient backdrop in your scene then it now takes longer to render 10 rays compared to 1 ray like it should

Hope this helps

Thanks,
Jason

I think it has to do with cores.. just set it to whatever raw cores you have in your machine(s)

Asticles
01-11-2018, 12:40 AM
I think it has to do with cores.. just set it to whatever raw cores you have in your machine(s)

Interesting!

JamesCurtis
01-11-2018, 09:27 AM
I'm a newbie when it comes to the inner workings of my machine. I have 5780 i7 processor in my PC, and it has 6 cores [12 render threads]. That means I should set mine to 6, am I correct?

MichaelT
01-11-2018, 01:56 PM
I'm a newbie when it comes to the inner workings of my machine. I have 5780 i7 processor in my PC, and it has 6 cores [12 render threads]. That means I should set mine to 6, am I correct?

yup.. try that. You can obviously try 12 too.. or any number.. but you'll get slower beyond that. But try and find the sweet spot for your machine. I'd guess it is around 6-8 at least.