PDA

View Full Version : Lassoe select with Mac with 2018



grafxstudio
01-01-2018, 02:06 PM
I'm not sure if I'm blind or it is placed where I can't find it but on a mac how do you lasso select with the new 2018 modeler. Tried it this morning and could not for the life of me select by holding the command button down and drawing out the lasso. Checked the manual and the videos couldn't find it. Help!!

rsfd
01-01-2018, 05:00 PM
after several LW-free years, I need to recap a lot.

But isn't Right-Mouse-Button Selection what you are looking for?
With "shift"-key to add to and "ctrl"-key to remove from selection?

jwiede
01-02-2018, 10:02 AM
I'm not sure if I'm blind or it is placed where I can't find it but on a mac how do you lasso select with the new 2018 modeler. Tried it this morning and could not for the life of me select by holding the command button down and drawing out the lasso. Checked the manual and the videos couldn't find it. Help!!

Make sure you're in "Mouse" mode, not "Tablet", and at least here (specs per sig) lasso select appears to work fine.

gerry_g
01-05-2018, 07:28 AM
not true, have tried everything, a wacom mouse functions just fine in tablet or mouse mode but a pen with the same key settings does not function correctly at all (this is only a LW 2018 problem). If I set the back modifier button to right click as per the mouse it only functions correctly if I air click in the viewport and let go, if I make contact with the tablet I cannot release the lasso without right clicking again, it is supposed to work with a Keyboard 'command' + 'right click' as per LW 2015.3 and as per Modo THIS IS A BUG and worse is impacting on pen use generally throughout the entire program, I found myself unable to select or delete a key in gradient node yesterday.

The more I think about it it is the inability to use 'command' as a keyboard modifier input that is the problem, LW is still very much a windows orientated product, plus ca change !

Work around for now, Leave settings in Tablet mode (makes no difference anyway) set back button on pen to 'Keyboard'-'Modifier'- and from the pop up window select 'Keys' to be 'control' and clicks to be 'right' then use action of 'Command' modifier on keyboard and back button air click to use lasso but don't touch the tablet.

rsfd
01-05-2018, 08:43 AM
as of now, I cannot verify this issue: pen lasso selection does work here correctly both with air-click or tip-click options.
Also, using the pen generally in Modeler or Layout UI does seem to work ok so far.
This is with driver 6.3.25-2 on 10.11.6 on Intuos4 .
(But I'd like to add that I've found Wacom's product quality both hardware and software (aka driver) -wise dropping constantly for years now).

gerry_g
01-05-2018, 04:58 PM
Well same tablet model same driver but on 10.12.6, grip pen or pro pen no matter, when set to default it results in having to make a second click to deselect the lasso if I make contact with tablet, on the other hand I can select points in the graph editor by just selecting them now without having to use a keyboard modifier, and yes in the last year I have had to downgrade from latest wacom drivers twice in order to keep them working correctly, quality control is not their strongest point these days

rsfd
01-06-2018, 08:19 AM
just had a look: Wacom in the meantime arrived at driver v.6.3.27-2.
But as you know, this may or may not help with your issue.

gerry_g
01-14-2018, 03:43 PM
so no fix yet with latest release, am running Sierra and latest Wacom drivers, can select sort of but not add to selection, mouse or tablet mode nada, and now wacom mouse is acting up as it seems to zoom unexpectedly when keyboard modifiers are used for various functions, all other apps are unaffected this is just LW 2018 specific.

sentience
01-31-2018, 11:37 PM
another LW2018 Mac user here, massively missing the CMD key functions as well (lasso, multi-select/deselect, add/remove edges in editEdges, etc etc)

quixote
02-01-2018, 01:24 PM
already posted, go to the upper mac menu with modeler open and go to "special" and turn off command mimics control modifier and you will

sentience
05-15-2018, 01:09 AM
already posted, go to the upper mac menu with modeler open and go to "special" and turn off command mimics control modifier and you will

Thank you for this 'fix', that completely solves this mystery would never have found it here. Beautiful!!

141712

Medyo Bastos
06-26-2018, 01:25 AM
Thank you for this 'fix', that completely solves this mystery would never have found it here. Beautiful!!

141712

...and this post nailed it. thanks!
am transitioning from my old 2007 PC with LW 10.03 to LW 2018 on my Mac. Still walking in baby steps but hopefully I'll be off and running sooner than soon. Cheers!

pstallo
08-25-2018, 08:08 PM
Thank you so much for this! I thought I was losing my mind!