PDA

View Full Version : 2018 and Transparency



rustythe1
01-01-2018, 01:46 PM
ok, as i didn't really use dielectric in 2015 for glass and things on buildings it may be this issue is there too, i noticed it in the demo content "spyder beach" as well as it appears materials do not respect compositing?
basically if you use the standard note (which appears to work the exact same way as the old surface editor) and set to transparent (no refraction) you can see what ever is composited in the back ground, so in this example i have an HDRI texture environment, however i don't want to see the environment in the renders (its just there for light and reflection) so the back drop is set to white and in compositing options is ticked to use backdrop colour,
however you can see here the transparent materials show the texture environment, not the backdrop like the standard material does
139026
anyone have any ideas or are we stuck with only using standard node when you can see all the way through a model (if you check out the spyder beach scene in content folder the car windscreen looks completely wrong as its not showing the comp image and just the environment)

rustythe1
01-02-2018, 05:09 AM
No body else do arch viz comps and see this as a problem? example glass tower blocks where you can see through the corners? cars, airplane/spaceship cockpits, interior viz shots, comping glass elements on tables?

Asticles
01-02-2018, 06:20 AM
I have tested and seems that is getting the alpha channel correctly, but backdrop is ignored on transmission.

As a workaround, for example on the beach scene, make the ground plane bigger.

Regards

139054

Maybe it is a bug

rustythe1
01-02-2018, 06:29 AM
yes, that's what i saw, alpha channel is correct, but backdrop ignored, solution is ok for that scene as you are looking down, but as soon as anything is above the horizon its a problem (for most arch viz comps you are probably looking up and i would have thought this will affect most film and tv effects?)

OFF
01-02-2018, 07:19 AM
Check the Surface Editor -> 'Shading model' tab -> set 'refraction options' to 'refract only'.

rustythe1
01-02-2018, 07:46 AM
yep, after seeing RHs new videos it clicked, however there is still a bug, i have the backdrop white, i have a texture environment and then an environment light sampling the backdrop, but the refraction and transparency is black as if its not sampling anything, so its a step in the right direction, just have to figure out exactly what background element is being sampled, or my guess is its because there is nothing there the ray goes to infinity and beyond, which must be black

rustythe1
01-02-2018, 08:02 AM
and, now what's interesting is that the alpha channel now shows the glass as solid and not transparent as when it does with raytrace backdrop!