PDA

View Full Version : apply multiple decals into an object



Ariandesign
10-29-2017, 04:34 AM
Hi to all.
Today I was trying to apply several stickers on a car, Trying to applying several image map from texture editor but I'm having a strange problem...
Every time I apply a new decal, the new one make disappear the older one....I'm using png with transparency, But it doesn't matter, even if I try to apply a very small sticker, it make disappear all the lower layer applied on the texture editor on the bodywork object....
i've also tried to change the blending mode of course, but nothing worked...I'm not understanding what is wrong :(

Do you have any suggestion?

Thanks

Ariandesign
10-29-2017, 04:43 AM
P.S
The strange thing is that I've this problem just in modeler, not in the Layout, where the decals works fine...

Sensei
10-29-2017, 04:43 AM
Do you have any suggestion?


Use Node Editor.. ? :)


Did you try if switching off interpolation and mipmapping (Image Editor) changes anything.. ?

Sensei
10-29-2017, 04:45 AM
P.S
The strange thing is that I've this problem just in modeler, not in the Layout, where the decals works fine...

Don't rely on OpenGL preview. It's just preview with many limitations. In Layout use VPR.

rustythe1
10-29-2017, 04:47 AM
if you mean in the standard openGL viewport, then yes this happens, they should render fine in layout VPR or final render, but the OpenGL usually only shows the top layer of your surface editor, i think its because it shows the open areas of the PNG as black and that overwrites the previous layer OGL, so if you need to tweak previous layers, best to do it in vpr.

rustythe1
10-29-2017, 04:50 AM
also set the tile repeat in both directions as reset as that should only show one instance of the image as a black square

Ariandesign
10-29-2017, 06:08 AM
Don't rely on OpenGL preview. It's just preview with many limitations. In Layout use VPR.

Hi Sensei,
Thanks a lot for your reply :)

Yeah for sure using Node editor can be a valid suggestion :)
Probably using Node editor I'll be able to solve the problem of the planar texture.....the problem of the planar texture of a decal applied to a side which is projected also on the other side, but in the wrong way because is not specular.....In some other software i can edit dhe texture depth and fix it....but I don't know how to do it in LW outside the node editor....

Yeah in the VPR i can see all the texture layers :)
Thanks :)

- - - Updated - - -


also set the tile repeat in both directions as reset as that should only show one instance of the image as a black square

Thanks a lot to you too Rustythe1 :)
Yes I've set up the repeat option to reset....and in VPR everything works fine,

Thanks a lot
Arian