PDA

View Full Version : Lightwave 2015.3 hanging on launch in Mac OS 10.13 High Sierra



David_CGC
10-02-2017, 08:52 PM
I haven't seen anything about this anywhere else, so I wanted to see if it was a unique problem, or to warn off others; after upgrading to 10.13 High Sierra, I haven't been able to open Modeler or Layout (Hub works fine, for whatever that's worth). The programs seem to be starting up, but hang before they get anywhere, requiring a force-quit.

gar26lw
10-03-2017, 02:31 AM
Ive had this on pc x64. I think I deleted configs to get things to work.

10-03-2017, 08:00 AM
http://forums.newtek.com/showthread.php?144072-Lightwave-on-Mac-not-responding&highlight=

Have a looksee if the answer is within.

Truly annoying.

David_CGC
10-03-2017, 06:13 PM
Well, you're both right. I tried pulling the various preference and config files living in Application Support, and Lightwave launched (in discovery mode). I tried reintroducing the old configs one by one, and just like in that thread, it is a problem with the license file.

Trouble is, none of the remedies worked. Neither moving nor renaming the license file had any effect (nor did reinstalling Lightwave). Downloading a fresh one from my account didn't change anything. Also weird, that thread is describing a problem with a multi-seat license. I've got a single-seat, non-networked license. I've still got my dongle plugged in, even though I don't actually need to anymore (unplugging the dongle also doesn't help).

Console gives me this while Layout is hanging (filtering for the word “Layout”).

default 16:54:55.155930 -0700 Layout WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.0 instead of 10.13.0. This is not a bug in Gestalt -- it is a documented limitation. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:
default 16:54:55.156231 -0700 Layout 0 CarbonCore 0x00007fff2e6ea3d8 ___Gestalt_SystemVersion_block_invoke + 112
default 16:54:55.156249 -0700 Layout 1 libdispatch.dylib 0x00007fff54a6df64 _dispatch_client_callout + 8
default 16:54:55.156265 -0700 Layout 2 libdispatch.dylib 0x00007fff54a6df17 dispatch_once_f + 41
default 16:54:55.156284 -0700 Layout 3 CarbonCore 0x00007fff2e67ada0 _Gestalt_SystemVersion + 948
default 16:54:55.156303 -0700 Layout 4 CarbonCore 0x00007fff2e67a5e6 Gestalt + 139
default 16:54:55.156320 -0700 Layout 5 QtCore 0x000000010498b156 _ZN9QInternal16registerCallbackENS_8CallbackEPFbPP vE + 194
default 16:54:55.156337 -0700 Layout 6 ??? 0x00000001048e8a0a 0x0 + 4371417610
default 16:54:55.176733 -0700 launchservicesd CHECKIN:0x0-0xac0ac 1459 com.newtek.LightWave.Layout
default 16:55:06.171619 -0700 Layout LSExceptions shared instance invalidated for timeout.

The only other thing I could think of to try is re-running the OS installer in case something went wrong with that.

ETA:
I did reinstall the OS, and that seems to have solved the problem. To be safe, I tried opening Lightwave without the license file in place first, so any preferences or cache files that were generating in the new system would be built clean, so I'm not sure if it was the reinstall itself that did it, or opening in discovery mode for the first launch. I'm sure not re-reinstalling to see if I can replicate the issue.

ConjureBunny
10-05-2017, 09:38 AM
If you have a problem like this in LW or any other Mac app, one thing you can do to help narrow down the cause is open Activity Monitor, double-click on the process in question while it's hanging, and click the 'sample' button. That will tell you what it's doing. It might be indecipherable gibblediegook, but someone familiar with Mac programming can probably decipher it for you.

-Chilton

gar26lw
10-05-2017, 03:59 PM
I'm just curious but do you guys leave lw configs at the default location or move them some place else and specify in the lw shortcut? If still issues, I'd try that.

Also, remember to check for that hidden file mentioned in the other thread.