View Full Version : material blender node not working?

10-02-2017, 02:22 PM
I'm using Lw 2015 sp3 and I just tested the material blender node. Am I wrong or the way It's supposed to work is to plug one mat in the foreground input, one in the background and using an image (B/W values) to blend between the materials? Because It's definitely not working for me. I can blend the diffuse/reflection etc but not the whole material using those two foreground/background inputs.
Any idea why? Is this node broken in LW 2015?

Thank you


10-02-2017, 04:53 PM
Try using Const > Scalar 1.0 then 0.0 as Alpha input to Material Mixer,
to verify whether mixing works correctly.

How are you verifying it? Are you using VPR previewer or F9 renderer?

OpenGL won't show anything useful..

10-03-2017, 11:04 AM
Thank you for your answer.
I checked VPR and F9, I know OGL won't show anything.
I'll check the scalar input tonight, I'm away from my computer at the moment. But unless the luma values of the mask aren't interpreted as scalar / values, I don't think the scalar node will make any difference. The native LW material mixer does work properly with the same mask and materials so I guess It might be a bug in the DP kit.
I'll let you know later about the scalar input as mask.

10-03-2017, 11:12 AM
You can always use my TrueArt's Node Library
node Flatten Material,
and it'll convert material to Color,
and then you can use normal color mixer.. (and then plug to Diffuse Shading)

10-03-2017, 01:31 PM
did you plug the alpha in like this, there is no one way to attach all the other stuff but this is one way and yes this is 15.3. whatever

10-04-2017, 01:56 AM
Thank you Gerry...I was referring to the material blender nodes (I made a mistake, not from DPkit but from Db&Wtools) not to the material mixer. Yes, the mat mixer (LW native) works perfectly and I think the material blender node is bugged with LW 2015 sp3. (plugging the scalar node doesn't change a thing)
Tried the TA node Flatten Material but got a crash.
That's ok, I'll just use the native material mixer, I was just wondering if anyone else had that problem. I'll contact Db&W directly to see if it's a bug.

Thank you for the help.

10-04-2017, 10:03 AM
Tried the TA node Flatten Material but got a crash.

?? I don't have any crash..
Can you show screen-shot of node tree, that caused crash.. ?

Do you have Windows or MacOS? 32 or 64 bit?

10-05-2017, 01:53 AM
Hello Sensei. Getting back to you when I'm at my desk later tonight (I'm out the whole day)
I'm using Win 7 64 bits.

Thank you for you time and interest.