PDA

View Full Version : Lightwave High DPI small mouse cursor



freeflyklown
09-27-2017, 07:20 AM
Hi all,

I use lightwave on a high dpi notebook. Everything is fine, except the mouse cursor in modeler and lightwave is almost invisible. Is there a way to make it bigger or change it's color? The way it is now, unfortunatly LW is not usable on this machine. Since this is my only computer, I would be forced to move to Blender or maybe Modo, because I simply cannot see the cursor. Any help is appreciated!.

Ztreem
09-27-2017, 07:25 AM
Send in a bug report or feature request so the devs can add this feature in future versions, if they not already done that. It's always good to make them aware of problems we users face.

If you can't change the color of the cursor, then you can change the color of the background i Lw to make the contrast bigger.

rustythe1
09-27-2017, 08:12 AM
yea, have the same on my 4k screens, its the plus shape cursor that's the problem, it has no white pixels, and ends up rendered smaller than background wire and the grey of lightwave, would be handy if there were a location these could be changed (as in maybe there is a cursor icon folder?)

madno
09-28-2017, 12:29 AM
seen that, been there.
Report sent times ago.
No fix since several versions.

gar26lw
09-28-2017, 05:25 AM
seen that, been there.
Report sent times ago.
No fix since several versions.

Excellent :-p

Please, please, please can we fix these type of ux issues.

tonyhall007
09-29-2017, 01:21 AM
I had a similar problem with my cursor moving about on its own when using a 4K monitor with Lightwave. I changed the Input settings to tablet under the Interface tab and it seem to sort it. Not sure if it will work for you.

rustythe1
09-29-2017, 07:30 AM
well here is something odd, magically I have just noticed my cursor has changed to a full size cursor same size as the windows on, and is now black and white in colour, so that would lead me to think this may actually be a windows/gpu graphic problem

ideart
09-29-2017, 08:04 AM
well here is something odd, magically I have just noticed my cursor has changed to a full size cursor same size as the windows on, and is now black and white in colour, so that would lead me to think this may actually be a windows/gpu graphic problem

Same thing is happening to me in one pc of mine. A windows restart fixes the cursor problem.

rustythe1
09-29-2017, 11:05 AM
and, setting to tablet did fix the jumping problem, however it removes the ability for the cursor to move outside the window, for example if you hold down the viewport pan button, the viewport will only move until the mouse hits the edge of the screen, in mouse mode you can infinitely move because the mouse cursor actually remains on the button with left click, bummer.

wingzeta
09-29-2017, 11:40 AM
and, setting to tablet did fix the jumping problem, however it removes the ability for the cursor to move outside the window, for example if you hold down the viewport pan button, the viewport will only move until the mouse hits the edge of the screen, in mouse mode you can infinitely move because the mouse cursor actually remains on the button with left click, bummer.

You may be able to fix your mouse jumping problem without tablet mode by right clicking on the modeler.exe going to Properties/ Compatibility, and checking the box next to "Disable display scaling on high DPI settings". Some menus can get cropped, but it works well overall and fixed the mouse control issue. Worth a try.

rustythe1
10-01-2017, 09:10 AM
didn't work that way for me, but I changed it to "System enhanced" and that seems to have fixed the jumping, unfortunately today my pointer shrunk back to microscopic and nothing seems to bring it back

rustythe1
10-03-2017, 01:58 AM
annoyingly the jumping came straight back, but, now I am sure its all windows behaviour, I have just noticed Photoshop cs6 is doing exactly the same, if its a windows based pointer its ok, as soon as you go over things like the navigator, histogram etc the pointer shrinks almost out of existence,