PDA

View Full Version : Graph Editor Help



Malorie
12-20-2003, 12:56 PM
I'm trying to get a nice repeat on my walk cycle and I can't seem to get the splines to match up at the repeat point. I've been digging and digging and can't seem to find an answer.

Thanks in advance,
Malorie

Malorie
12-20-2003, 12:58 PM
I sould mention that in the picture are the two Z positions of the feet. The areas circled should be equally smooth.

I've also tried every differint type of spline. It seems as though the first key's spline can only start perpendicular to the virtical frame line.

toby
12-20-2003, 02:25 PM
the keys need to be evenly spaced and at equal values to be perfeclty smooth (too perfect is unrealistic though).

One key at the peaks of those curves might be easier.

'pre-behaviour' and 'post-behavior' only work before your first keyframe and after the last, so since you have keys at the start and the end it has no effect.

Malorie
12-20-2003, 04:59 PM
Thanks. :)
I seem to be suffering from a summer away from LightWave.

You're right, a key at the peak and removing the others did the trick. I looked up an old walk cycle from last year and that's the way I did it before.

I work most of my cycles in graph editor and get them perfect first, then add some randomness or imperfections after. I find it goes much faster then trying to keyframe everything. I also don't end up with a bunch of junk keyframed that I don't need. It's a bunch easier to adjust the timing of the various movements also.

Anyway, thanks much for the input. :D
Malorie