PDA

View Full Version : open gl settings in nvidia for modeler smooth open gl wires?



prometheus
07-10-2017, 07:03 PM
Darn it, I canīt recall which settings should be changed, we had a thread and a post about that on which setting should be changed in nvidia to make the wireframes in opengl and modeler smooth.

I think it was about turning of program controlled aa settings, not sure if it was global or by setting the application nvidia settings.

Itīs also funny that my system turns lightwave layout exe in to naming it to trimble sketchup..what the?

Anyone who knows the settings or the thread..I guess I may find it sooner or later, but taking a shortcut here:)

gar26lw
07-10-2017, 10:04 PM
I think its in the nVidia control panel. manage 3D > program settings > Add Lightwave/Modeller and set AA on/enhance

prometheus
07-11-2017, 12:34 PM
I think its in the nVidia control panel. manage 3D > program settings > Add Lightwave/Modeller and set AA on/enhance

Thanks, but nope, that doesnīt seem to be working, added lw modeler, and the proper 64 bit as used (nvidia is also renaming the icon added as cst microwave..weird) just as it names layout trimple sketchup without even having that installed.

Edit..
You can not use AA enhance, since in such case you also need to set appropiate AA in the related software...that is in lightwave modeler, but Lightwave doesnīt have such options except for certain grid settings in layout, so what you should do is use (not sure about the proper english term) compromize settings? or override or infringement settings?
but One should still set the AA to high (8x) in the menu above, So that worked.

Thanks anyway..


137354

madno
07-12-2017, 12:22 AM
That works in my case.
Restart of Modeler needed to take effect.

137358

prometheus
07-12-2017, 11:16 AM
That works in my case.
Restart of Modeler needed to take effect.

137358

what do you mean? that is exactly what I said would work, override, not just set the aa to enhance, or did you just confirm that :)
and yep, restart of modeler needed..correct.


good, you also got cst microwave studio naming on the lightwave modeler icon:D

madno
07-20-2017, 10:59 PM
I switched to "Enhance" instead of "override" now. Both settings work, but with "Enhance" switching from one to multiple viewports (0 key on num pad) and vice versa is faster.

gar26lw
07-21-2017, 07:03 AM
Good to know

djwaterman
07-21-2017, 09:40 AM
I did the same but I see stair stepping with "Enhance" so I went back to override. Before all this I had just set modeller global setting to video editor, as I wasn't super concerned about AA in Modeler and preferred the faster feed-back.

madno
07-22-2017, 01:35 AM
Just tried. You are right, with override the quality is even better. Stepping is nearly gone. But switching the Rendering Style (e.g. Textured Wire to Color Wireframe) takes longer then. Maybe we can't have the best of both worlds.

madno
07-22-2017, 02:44 AM
Have to take back what I wrote.
It seems that "Enhance" does nothing. Whether it's "App Controled" or "Enhance" does not effect how the aliasing looks.
"Override" on the other hand gives a much better result.
My concluson now is:
For good antialiasing only "Override" is of use at the cost of speed when switching viws or rendering styles.

prometheus
07-22-2017, 03:27 AM
Have to take back what I wrote.
It seems that "Enhance" does nothing. Whether it's "App Controled" or "Enhance" does not effect how the aliasing looks.
"Override" on the other hand gives a much better result.
My concluson now is:

For good antialiasing only "Override" is of use at the cost of speed when switching viws or rendering styles.


Yes...thatīs what I found out as well, so I was a bit confused you mentioned that enhance would work, but all fine and dandy for trying out and making sure:)

madno
07-22-2017, 04:35 AM
Sorry for the confusion. Anyway, hope one day LW3DG will incorporate some up to date viewport tech in Modeler.