PDA

View Full Version : TriCaster 40 v.2 Mic Input/Headphone Out DISTORTION



sweed0524
06-12-2017, 08:57 AM
Hey everyone,

I have been using my TC40 v.2 since Feb. 2014 - having no major issues up until now.

The other day I went to plug my mixer's main out to the TC40's Mic input (the setup I have been using the entire time) only to hear and see that the signal was distorted and half there. So I start really listening and when I unplug the 1/4" cable from the TC40 (nothing else plugged in, just monitor and HDMI) I can hear the heaphone jack has a buzz in it!! So at this point, I have nothing plugged into the TC40 and I have a buzz/hum in the headphone output. The microphone input is also not functioning properly but there is a connection being made between mixer and TC (albeit a broken distorted one). Both analog input and output are working fine as of now and that is what I am using currently.

I immediately freak out because I know this is not good. I call NewTek CS and they agree that most likely it is a hardware issue that will need servicing. $195 or $695 for the repair depending on the variety. We both kind of agreed that it was more than likely going to be the $695 fix as it was looking like a major hardware replacement job. Not the news I wanted.

ANY IDEAS?? ANY THOUGHTS?? ANY REPAIR PLACES BESIDES THE $695 + SHIPPING NEWTEK :newtek: WANTS??

I am a freelance live stream videographer so this TC is my bread and butter and not only do I not have the money to fix this I can't really go without it for long.

Thank you in advance to anyone that may read this and have any insight on the input/output issue or may have some ideas on how to get it fixed else where or buy spare parts to do it myself.