PDA

View Full Version : How to speed up LW viewport



genesis1
06-01-2017, 09:06 AM
Is there a way to speed it up? What I mean is...will splashing some cash on a new gpu with 4gb memory speed up layout and modeler viewport? Currently I am only running a 1gb gpu card and high poly scenes stutter while moving around the viewport.

Ryan Roye
06-01-2017, 09:51 AM
No.

Memory will only allow your computer to store more information without crashing or spamming the Hard Drive cache file, or dumping information to load new information. So, if you are hitting memory ceilings with the amount of models, textures, vertex cache files, etc... then its time to upgrade. Furthermore, a lot of Lightwave's viewport functions use CPU memory. GPU memory will not improve the vast majority of Lightwave Layout's functions.

There are many, many different factors that go into how efficiently your scene will play back frames.

- Transparency on/off: LW doesn't handle lots of transparency well
- Deformers: You can check whether deformers are a big issue in your scene playback by comparing how fast it plays with deform enabled/disabled. Some deformation effects contribute more lag than others (IE: Inertia in the deformers tab)
- Density of geometry in scene. You may need proxy objects to boost performance.
- Whether the dope track (the timeline just above your playhead) is expanded or not. The more keyframes that are displayed, the slower things will get. Enabling channel edit mode in the right click menu will help this to some degree since it only processes channels related to your current tool.

There's a bunch of other things too but the above is what I run into most often.

genesis1
06-01-2017, 10:14 AM
No.

Memory will only allow your computer to store more information without crashing or spamming the Hard Drive cache file, or dumping information to load new information. So, if you are hitting memory ceilings with the amount of models, textures, vertex cache files, etc... then its time to upgrade. Furthermore, a lot of Lightwave's viewport functions use CPU memory. GPU memory will not improve the vast majority of Lightwave Layout's functions.

There are many, many different factors that go into how efficiently your scene will play back frames.

- Transparency on/off: LW doesn't handle lots of transparency well
- Deformers: You can check whether deformers are a big issue in your scene playback by comparing how fast it plays with deform enabled/disabled. Some deformation effects contribute more lag than others (IE: Inertia in the deformers tab)
- Density of geometry in scene. You may need proxy objects to boost performance.
- Whether the dope track (the timeline just above your playhead) is expanded or not. The more keyframes that are displayed, the slower things will get. Enabling channel edit mode in the right click menu will help this to some degree since it only processes channels related to your current tool.

There's a bunch of other things too but the above is what I run into most often.

Well i'm running a 6 core cpu with 16gb memory...it's just when I pan around the objects or move the objects while I'm placing things that it can sometimes be a bit jerky in high polycounts. Thanks for the info though. Thought that might be the case. :)

Sensei
06-01-2017, 10:50 AM
Is there a way to speed it up?

Switch display mode of item to f.e. bounding-box..
If you're using Sub-Patches, you can set Display Sub-Patch Level in Object Properties.
Remember that Catmull-Clark Sub-Patches have 2^n * 2^n * 2 triangles,
while traditional Sub-Patches have n*n*2 triangles.
So Display Sub-Level 4,
will make 2^4 * 2^4 * 2 = 512 triangles from single CC,
while it'll make 4*4*2=32 triangles from single traditional Sub-Patch.

prometheus
06-01-2017, 11:17 AM
Is there a way to speed it up? What I mean is...will splashing some cash on a new gpu with 4gb memory speed up layout and modeler viewport? Currently I am only running a 1gb gpu card and high poly scenes stutter while moving around the viewport.

which module is most troublesome? modeler or layout?
for high density polymeshes in layout, always use 64 bit lightwave, not 32...unless some special plugin is only available in layout.
Thereīs also the opengl geometry acceleration, found in preferences/Gl tab...and you would probably like to go with buffered (vbo) geometry acceleration and not streaming.
various shading methods can slow down as well.

Also...polys in flat shading mode in modeler, if you for instance have a 1.3 million poly object in modeler and try to orbit with the rotation handles for the viewport, it will stutter, but in smoothing shading it will be much much faster...weird isnīt it, It has to sort of calculate some sort of unweld I think, so go for setting viewport display to smoothing in such case, or textured or textured wire.

genesis1
06-02-2017, 05:29 AM
Yes I do follow most of what you listed there...the stuttering is livable...it's just when I'm working on a character with high polycount (the face is quite detailed) I have to change to bounding box to move my perspective around the object smoothly, but sometimes I want to adjust certain things so need the detail on and this cause great jumps when your Trying to move something just a tiny bit. I then have to go to the left and type in numbers so it moves in smaller movement. I can live with it, just annoying at times so was wondering if there was a way of speeding it up. Either with a better gpu, which I know understand won't make any difference in viewport, or maybe adding even more ram? :)

genesis1
06-02-2017, 05:43 AM
Oh...i'd forgotten about reducing sub-patch level...that has smoothed things out more. So that's helped. Thanks.

Sensei
06-02-2017, 05:43 AM
Prefs > Display
Dynamic Update drop-down Delayed mode,
and Bounding Box Threshold,
worth to check options.

If quantity of polygons in scene is higher than mentioned in Bounding Box Threshold (and Delayed mode is set),
then Bounding Box mode is automatically switched on objects, and switched off after stopping movement.

genesis1
06-02-2017, 05:53 AM
Prefs > Display
Dynamic Update drop-down Delayed mode,
and Bounding Box Threshold,
worth to check options.

If quantity of polygons in scene is higher than mentioned in Bounding Box Threshold (and Delayed mode is set),
then Bounding Box mode is automatically switched on objects, and switched off after stopping movement.

Tried that...reducing bounding box reverts to skeleton view while moving which could help in certain circumstances. Changing display from interactive to delayed doesn't seem to make any difference. So far reducing subpatch to 1 and/or just changing to shaded solid helps the most so far. :)

https://youtu.be/lW9_R4jiRfE

Sensei
06-02-2017, 01:12 PM
Changing display from interactive to delayed doesn't seem to make any difference.

Too large Bounding Box Threshold..

It's quantity of polygons.

1000000 = 1 million polygons.

Default is.. 4000000 = 4 mln polygons to switch to bounding box..

madno
06-02-2017, 10:01 PM
I made a quick screen recording of a static scene with around 10 milion polygons. Graphics card is a Quadro K6000 (12 GB). But I read in a post that the smaller Quadros will also give a good viewport speed. Does not only seem to be the ram but the driver and how LW uses the card.

https://vimeo.com/220096159

Jarno
06-02-2017, 10:24 PM
Frontface wireframe is known to be slow. It has nothing to do with the GPU. LW basically ends up going through each polygon and checking if it is facing towards or away from the camera on the CPU.

ianr
06-07-2017, 09:01 AM
jARNO

People mentioning a turntable in LW

Can You & Matt whip one together?

50one
06-07-2017, 09:21 AM
jARNO

People mentioning a turntable in LW

Can You & Matt whip one together?


Yes, please so can I scratch and mix my fav tracks.

magiclight
06-08-2017, 01:42 PM
Turn of antialiasing of the grid, turn of any other anti aliasing you might have enabled (check settings for video card so they don't override application settings).

Use fewer viewports if possible, every open viewport adds a lot of overhead.