PDA

View Full Version : Feber Fx with stains at the render! Geeting crazy!!!



tuovni
05-28-2017, 10:14 AM
Hello, Im trying to do a fur with Fiber Fx and all was working ok until I come to the render time. Is where I keep stacked because of some stains done by the final render. I think Ive tried everything but it persist. Im using Distant Light but When I changed to Area Light was worst. I thougth It could be a AA problem but nothing changed even I changed the camera from Perspective to Classic but the stains doesnt desapear.

Please, Im getting crazy!!! Someone have an idea which could be the problem? :confused:

Thanks!

Oldcode
05-28-2017, 12:15 PM
One thing I can think of is do you have any geometry in that area that you are trying to make invisible? If yes, go into the Surface Editor and make sure the Diffusion on the surface you want to be invisible is set to 0%. Even if you have Transparency set at 100% or higher, if you have any amount of Diffusion, it will show artifacts like this.

Hope this helps. Good Luck,

Dexter2999
05-28-2017, 03:12 PM
You have indirect bounces set to 2?

I'd bump that up.

tuovni
05-28-2017, 06:28 PM
Oldcode: Theres no hiden geometry.

Dexter2999: Ive set it up higher but no change.

MAUROCOR
05-29-2017, 07:36 AM
Try to change your FiberFX settings to VOLUME ONLY.

Kryslin
05-29-2017, 12:28 PM
Unless you need to render 2pt polygons, I'd turn off Render Lines. I only have it on for previews, and after I've turned Sasquatch/FiberFX off.

Hmm, 2 things I'd try, 1 at a time :
Increase the value under ray recursion until the problem goes away. If it hasn't gone away by a certain value (say by double or triple the original value), that wasn't it.
Increase Shadow depth under FiberFX Shadows for point sample.

I'd also increase Shading and Lighting samples; I use 3 Shading / 6 Lighting for previews. Still quite fast.

tuovni
05-29-2017, 09:25 PM
Thank you very much to all, finally I could solve the problem changeing the settings to "Volume Only" like MAUROCOR said. I dont have any idea why but the look and feel of the render is very different. Is like you have two differents hair depending which setting you choose.

Kryslin: I tried your suggestions but sadely nothing worked.

I have an idea why this bug occur but I couldnt probe it yet. I used 6 different surface for this fur and I suspect that it makes something strange in the calculation. I didnt work to much with the fiber but it never before ocured to.

May be someone have a better idea.

Again thank you very much to all!!!