View Full Version : Help! I broke LWCAD5.2

Paul Brunson
05-18-2017, 02:31 PM
So I finally got LWCAD. Been meaning to for years but sadly 3D is mostly hobby these days. Anyway I was playing with all the various features and I seem to have killed it. I can't get curves to draw properly with any of the tools, line tool, circle, cylinder etc.

First screenshot: that should be a cylinder. But instead its this wacky triangle thing. Any suggestions on how to fix it?

Second screenshot: It should be drawing a curve. Instead its all straight lines and loop is closed when it should be open.

136822 136823

05-18-2017, 06:44 PM
Ya, this is kind of a known issue. I'll do that with circles, arcs, and several of the other tools.

Try just manually re-adding the LWCad plug-ins (think it's really only one of them but can't remember which now) and that should clear things up.

Paul Brunson
05-18-2017, 07:24 PM
That worked! Excellent, thanks for your help! Back to playing with LWCAD. :)

05-18-2017, 07:33 PM
Just listing out the things I know can cause seemingly odd behavior with LWCAD in my experience:
- If you have LW Display Options: Grid Snap ON, it can "fight" LWCAD in its snapping behavior, as I recall, even when GRID=OFF in the LWCAD Snap panel. Maybe others can elaborate. I haven't been using LWCAD for my last project.
- LWCAD seems to work best for me when I only have a single layer set to FG.
- There are times when I recall I seemed to have to explicitly set UCS via the LWCAD UCS menu.

Again, sorry this is a little vague since I haven't been using it super recently.

05-18-2017, 10:03 PM
That worked! Excellent, thanks for your help! Back to playing with LWCAD. :)

Good deal. Enjoy

I know there are some other issues with the 5.x version that Snosrap has pointed out to Victor & will hopefully get address in the next release. He's generally pretty on top of fixes & they're nothing that are game stoppers.