PDA

View Full Version : PySide support



sinokgr
05-03-2017, 07:59 AM
Hi Guys,

I've built a little system for the studio I work with PySide in Python and it currently supports 3dsMax, Modo, Unreal and a Stand alone version. I wanted to add support for LW as well so I decided to see if I could get PySide working in LW.

I wrote the below simple script and tried run it. but I'm getting the following error.
136714

I searched online and I couldn't find much. The only thing I read in another post here, was about x86/x64 bits. Both Python and Lightwave are x64.

Any ideas?

Here's the code.

import sys
sys.path.append("C:/Python27/Lib/site-packages")
from PySide import QtGui

__author__ = ""
__date__ = ""
__copyright__ = ""
__version__ = ""
__maintainer__ = ""
__email__ = ""
__status__ = ""
__lwver__ = ""

m = QtGui.QWidget()
m.show()

Thanks,
Nick

Stardust
08-12-2017, 11:12 PM
Any luck on this?

Cryonic
08-13-2017, 12:14 AM
What version of QT do you have installed on the system and what version is PySide trying to use?

https://wiki.qt.io/Setting_up_PySide

To check what version of Qt is used to compile PySide, launch a python console and type:
import PySide.QtCore
print(PySide.QtCore.__version__)

The result should be something like 4.7.4.

Since the Qt version used to compile PySide may differ from the one used to run it, you might also want to check the current running version of Qt:
print(PySide.QtCore.qVersion())