View Full Version : Genoma 2 Biped Rig - Weird Arm rotations after using

04-04-2017, 11:35 PM
Having an issue with Genoma rig. I want to use more than 1 character in a scene.

My steps:
1. Model and add Genoma2 Biped, save object.
2. Import object into Layout and Create Rig.
3. Select control (any will do) and then hold Shift and right click in scene. This selects all controllers.
4. Run rename script from ( RenameIKFKControls.rar )
5. Controls are prefixed with model's name.
6. I leave the character in TPose and will create a new scene and use Load from Scene to load character later.
7. Save .lws scene.

All works accordingly. Here is the issue: When I create a new scene and Load from Scene and load my character from the TPose scene, the characters arms rotate at the elbows; even though, I did not create any keyframes or animate anything in the TPose scene. I have tried looking at the Graph Editor and each of the arms bones and controls, but there are no keyframes in the Graph Editor associated to any of the arm bones or controls.

I have tried to save out a TPose scene with animated arms; but, when I try to load from scene again, the arms just rotate around the elbows. There are no keyframes.

I'm perplexed because a few weeks ago, I was able to load 2 characters into a new scene (from both their respective TPose scenes) and animate them. When I reopen that scene, all is fine.

Anyone run across this issue before?

Here is a video showing the rotating arms: https://youtu.be/0L5TF3uGN7o

In this scene, I used Load from Scene to bring in my character from my TPose scene and loaded a few objects. I then posed the character on Frame 0 (no other keyframes exist). I then save this scene under a different name. When I reopen the new scene, the arms are rotating.

I am using LW 2015.3, on Win 10, i7, NVidia 940M, Surface Book.

04-05-2017, 06:02 PM
Ok, just tried another model and my setup steps worked with that model. Could a model actually affect Genoma Rig and cause eradict, non-keyframed movements??

04-06-2017, 10:26 AM
The problem is with names for things as referenced in expressions... the movement you're seeing isnt some non keyed move, its an expression unhooking. Most common cause... spaces in names of things (including the mesh file).

04-06-2017, 04:19 PM
Thanks for the suggestion RebelHill. I checked and no spaces. I reflected back on when I was adding the Genoma rig in Modeler and it must have been a weird mode or I double clicked on something (still can't recall what it was) but I attempted several times to add the G2 Biped rig and Modeler kept prompting me to SAVE the "human_rig". I was only clicking on the preset to add it. So, I think it was a goof or weird mode or Modeler got confused, etc. Also, at one point, I had to hit the spacebar to actually see the mesh of the model. Suffice to say, I think it was just a fluke of some sort. All other models see to be working fine.