View Full Version : ScreamerNET and Instanced objects - No Go.

ben martin
04-01-2017, 06:53 PM

I’m still using LW 11.6.3. :)
Most of the time I have no problems rendering regular scenes in ScreamerNET, but today I tried to render a forest using instanced trees.
All objects that are not instanced render just fine on ScreamerNET, but NOT the instanced trees… any clue?
After tried with LW native Instancer, I even tried with DPInstancer for the trees but to no avail... same result, no trees on the render.
If I render the scene in Layout, all renders just fine but not on ScremerNET render session.
Am I missing something about instanced objects and ScreamerNET?
Anyone noticed this problem before?

Many thanks in advance.


04-01-2017, 09:22 PM
Could you try simpler scene: make sphere, instance it? And check whether it's working.
Also there is Item Clone Instancer tool. Did you try whether it's working or not?

04-02-2017, 01:03 AM
i've never had trouble using Instancer or DP Instances with ScreamerNet. I typically render though BNR or another controller but that shouldn't make a difference because it still uses LWSN to render with. I don't use 11.x any more but, FWIW, all the tombstones and grass that appeared in the Brudders music video preview I posted a few years ago was done using LightWave 11.5.3 with Instancer and rendered with LWSN.

Could it be that your LWSN is using older configs? Like maybe for an older version of LightWave? I would also check that the config used by LWSN has all the necessary plugins properly added, and is properly pointing to the shared directory where you store your plugins.

Or, is it possible the source objects used by Instancer aren't available to LWSN? Make sure they objects are in the scenes's content directory and that the directory is shared. Ideally, this should be on a network drive, or (less ideal but okay) on a local drive that's accessible by all computers on the network. This could explain why it renders locally but not over a network.

ben martin
04-02-2017, 06:50 AM
Oh... what a shame, I found the culprit.
The LW-LSN shortcut config line was changed and instead of "X:\bin\Layout.exe -cX:\config -0" it was changed for "X:\bin\Layout.exe -cX:\bin -0". The bin is not the right place to store the global config files.
I wonder how did this happen tho.
Maybe a previous scene that was wrongly configured screwed it all up.
Anyways, it's proven that I can't let the kids play with my toys.

Thanks for the suggestions Sensei.
After read Greenlaw clues, I decided to peeks all the config files and found the problem.
I was not inclined to this because all worked fine the last time and since I don't remember changing anything, it was not making any sense to me.. but yeah.. the problem was there.

Hey G. long time we don't chat.
I see that you are now kicking for DreamWorks... that's awesome after all that went no so great in the past.
How is your Kinect mocap studio working, have you been able to get good data from it?

Do you still have the time for run your personal projects?
Disclose a bit about what you are up to. ;-)