PDA

View Full Version : radiosity glitch



vonpietro
03-09-2017, 10:17 PM
Encountered a weird glitch

A friend has a hall way and was trying to light it and had radiosity turned on - and i kept giving him ideas to make it work even put a value of 10,000 for intensity and yet nothing.

when he gave me the scene and i went through it, it turned out at that the illumination source some sconces had a 5% transparency . This little bit was enough to turn radiosity off completely.

With no lights, i nixed the transparency and suddenly just a low value of 100 for intesnity was enough to light the scene well with only 75% luminosity - so it was on finally and working.

still - This is the first time i ran into transparency on a emissive object killing radiosity.

anyone else experience this bug?

MichaelT
03-09-2017, 11:56 PM
I think I'd need to see a scene like that myself.

Update:

Nope.. I'm not seeing that myself. Which version of LW is it?

Update #2:

Aaah.. now I see it. But only in VPR.

vonpietro
03-10-2017, 12:09 AM
2015.2

as soon as i turned off the transparncy radisoity started working, with the transparency it just would not work.

MichaelT
03-10-2017, 12:32 AM
But you have this behavior in the final render as well? Because like I said, I could only see this in VPR.

gerry_g
03-10-2017, 03:15 AM
sounds like BS, true there are situations when transparency on an object can render black if the refractive index is not above the default value of one but I'm thinking here is ray traced transparency checked on in globals

Ztreem
03-10-2017, 03:46 AM
Uncheck draft mode in VPR and activate use transparency in GI settings and everything is fine.

Danner
03-10-2017, 05:00 AM
An odd behaviour for sure. I've had scenes with large luminous geometry that was hidden from the camera and reflections but it blocked radiosity calculations behind it, so some noise was present, I had to give it a little object dissolve to let radiosity rays through. So I understand why someone would add transparency to something like that.

jwiede
03-11-2017, 09:21 PM
Just tested and cannot reproduce here (LW2015.3, Mac64). If "Use Transparency" is enabled, radiosity is computed regardless of whether emissive surface is transparent or not (VPR & F9).

Schwyhart
09-29-2017, 12:08 PM
I'm having this issue now. In VPR (Draft mode unselected), the image is completely blown out. In the render, I can barely see anything.
I turned off Radiosity and the image seems just barely over exposed, but when I turn it back on and render the image is very dark and you can barely see anything.

I have linear lights inside of cylinders for florescent lights. Light geometry is set to 90% transparent, and 10% dissolve...doesn't help. I tried turning off the geometry and rendering, it doesn't help. The only thing that makes it not dark is turning off radiosity.

rustythe1
09-29-2017, 12:36 PM
what I tend to do here, is put the glass of the lights inside a separate layer of its own then have the lights exclude that layer, that way no problems

gerry_g
09-29-2017, 01:11 PM
The glass object needs its ‘object’ -‘render’ settings altered, tun off cast shadow