PDA

View Full Version : Strange problem with Motion Mixer



squarewulf
02-28-2017, 11:03 AM
I have a car rig using nodal motion, I animate it. I create the actor in motion mixer using everything in the car hierarchy. I then create the motion for the desired frames, but when I add the motion it plays back wrong. Items are shifted and rotations are incorrect. I'm at a loss, this usually works and I don't think i'm doing anything differently.

hypersuperduper
02-28-2017, 11:08 AM
Are you using any expressions or channel modifiers? If so you will need to use motion baker for anything that they read.

squarewulf
02-28-2017, 11:14 AM
Are you using any expressions or channel modifiers? If so you will need to use motion baker for anything that they read.

I am not

hypersuperduper
02-28-2017, 11:22 AM
Ok. The reason I ask is that I have had similar issues using motion mixer if I have something that needs to read keyframes in my case it is usually channel modifiers. My go-to solution is to create a null with motion baker that is same-as-item constrained to the item I need the modifier to read. You may need to do the same with nodal motion. Motion mixer probably evaluates after nodal motion. Can you swap the order of the MM driver and nodal motion? That might fix it.

squarewulf
02-28-2017, 12:01 PM
Okay so i've sorted it out. Switching the order did help fix half of it, thanks hypersuperduper. But another problem was my car was aligned to path, and at one point the heading switched from 180 to -180, motion mixer didn't like that.