View Full Version : Motion mixer stuck in edit motion mode

02-23-2017, 03:25 AM
I have an issue with motion mixer. I like to use it for organizing my animations despite some of its problems. I have one recurring issue that is quite a pain. If i am in the process of editing a motion and I save and quit or layout closes Motion mixer gets stuck in a weird state.

It gets stuck in edit motion state, so the motion I was editing is in the timeline, and the Motion mixer timeline is greyed out, but I can no longer exit the edit motion state. I feel like I have solved this issue before, but I can't figure how I didi it. It feels like this is simply a flag that gets set in the file when I enter edit mode that gets unset when layout restarts.

Anyone know how to fix this beyond just making sure never to save while in edit mode?

02-23-2017, 04:58 AM

Issue Solved (sort of)
I managed to get out of edit mode by opening the scene in a text editor and changing the ActorState and TrackState from 0 to 1 from the actor and motion. Then motion mixer was responsive again and the motion I was editing was empty but the keyframes were still in the timeline and could then be copied into the empty motion using RH animation Toolbox copy/paste motion.