PDA

View Full Version : Help - Holes in my geometry? Bad Render?



Avebeno
01-16-2017, 03:41 AM
Howdy from Phoenix!

I've been working on an asteroid I need for a show I am working on, and every iteration seems to have the same problem, and I can't find the solution.

I have started with the Ball Tool and created Globes or Tessellation shares as my base, that I have subdivided as Smooth or Metaform Polygons...
SubPatch has been toggled on and off, I have used displacement maps and bump maps and every time, I get these errors in my renders.

Sometimes I get triangular shadows if ray traced, as well.

A render should be attached to this post. Does anyone have a suggestion?

Thanks in advance!

Ben Avechuco
An on and off lightwave user since 1992 or so.

135643135643

fishhead
01-16-2017, 03:50 AM
Hi Avebeno, a bit hard to tell from only that one render but to me it appears as if there are overlapping polygons rather than holes... Is there a chance that you accidently somehow doubled your mesh in the process?!?

cyclopse
01-16-2017, 03:56 AM
Hi Avebeno, a bit hard to tell from only that one render but to me it appears as if there are overlapping polygons rather than holes... Is there a chance that you accidently somehow doubled your mesh in the process?!?

Damnit, he beat me to it. Another thing is... at times (not always) spheres as metaforms has caused me issues. It's always best to start with a box and metaform that (and work with quads... not triangles until you freeze it).

Avebeno
01-16-2017, 04:39 AM
Lorenz,
Thanks for you reply.

No, I don't see how I could have. I start with a sphere and use the Magnet Tool to shift some points on the model.

- - - Updated - - -

Hmmm. I shall give that a try. Thank you!

bazsa73
01-16-2017, 04:52 AM
Howdy Ho!
That's duplicated geometry in my opinion.

bazsa73
01-16-2017, 04:54 AM
What if you click on Unify Polys button in modeler? Or zoom in on the geo and see if there are almost overlapping polys? Or there could be more than one geo layer in Layout?

Danner
01-16-2017, 07:22 AM
Something similar to this also happens if your "Ray Precision" is too high in the render settings.135644

Paul_Boland
01-16-2017, 05:39 PM
Have you applied Jitter to non-triangular polygons? If so, that could be the problem. I experienced something similar in my early days of working with and learning Lightwave. The solution, Triple the model so all polygons are three point polygons. See if that helps. Triple is under the Multiply tab in Modeler.

NeonZ
01-16-2017, 05:47 PM
For the holes, do they typically appear near quads or triangles? If quads, I usually see this behavior when a quad is not smooth and the surface angle is too large for the render engine to smooth out properly. What I usually do in these circumstances is convert everything to triangles (ala Paul_Boland) in a test object (Or at least the affected area) and then do a quick render test using the modified triangle-only object. That at least tells me whether it is a geometry issue. You could also select the polygons around these holes and then Smooth out the geometry as a test.

Now, you also indicate that you've toggled SubPatching on/off. I also see similar render abnormalities when an object has a combination of regular polygons and sub-patched polygons. This is normally a mistake and happens to me when I don't make sure I have all of the sub-patched polys selected when toggling on/off. So maybe there could be sub-patched polys at the holes that are connected to normal polys. Just a thought.

The stripes on some of the polys indicate overlapping geometry as others have stated. For overlapping geometry (in general), try hitting M in modeler to merge points. If no points are merged, then overlapping geometry is caused by two polys attached to the same point, facing opposite directions. If points are merged, then it most likely could be two objects occupying the same 3D space with their polygons pointing in opposite directions (think Copy object, flip normal, Paste object). Merging and Unifying Normals usually resolves this. But this is just my two cents!

Sensei
01-16-2017, 06:35 PM
Help - Holes in my geometry? Bad Render?

I don't think so what you see are "holes". Try changing color of shadow in Light Properties (or Backdrop color in environment settings)
If color of these "holes" will change accordingly to Shadow Color that you just changed, it will confirm that they are really shadows.


In Object Properties > Render,
there is option Shadow Offset.
Did you try to adjust it slightly?

jeric_synergy
01-16-2017, 06:48 PM
Just to settle our minds, run MERGE POINTS followed by UNIFY (POLYS).

LW default spheres have triangles at the poles, and are non-optimum candidates for subd. Try to use "Quad Spheres" instead, google them. You'll need a Legacy plugin supplied by LWG to use the Quad Spheres plugin. (Basically, it's a cube w/SPHERIFY run on it.)

IIRC you can sometimes quelle render errors with different smoothing parameters in the Surface panel.

Snosrap
01-16-2017, 08:55 PM
I'm with Sensei on this. Try some different light types with and without shadows turned on.

spherical
01-17-2017, 09:25 PM
Just to settle our minds, run MERGE POINTS followed by UNIFY (POLYS).

That'll clear exactly duplicated/flipped geo, but not overlapping polys. As a debugging step, try turning off Self Shadow in Object Properties and see what changes.

Avebeno
01-19-2017, 02:03 AM
Here is what I found:

With Self Shadow OFF, but Cast Shadow, and Receive Shadow ON... The dark spots still appear.

With Receive Shadow, no dark spots appear.

It seems they are shadows. If I make the shadow color RED, the dark spots are RED.

I tired a Directional Light with Raytrace on, and Spotlight with a shadow map as well.

I did a version with triangulated geometry.

I made sure to "MERGE POINTS followed by UNIFY (POLYS)" with no change. It was reported that no points were eliminated, and no Polys has been eliminated.

Avebeno
01-19-2017, 02:13 AM
Though I would like to figure out what is wrong, I made an alternate asteroid that is working for now.

I started with a simple sphere with no modifications in modeler, and added some displacement maps in the object "Deform" tab.

Sensei
01-19-2017, 02:47 AM
Here is what I found:

With Self Shadow OFF, but Cast Shadow, and Receive Shadow ON... The dark spots still appear.

With Receive Shadow, no dark spots appear.

It seems they are shadows. If I make the shadow color RED, the dark spots are RED.

I tired a Directional Light with Raytrace on, and Spotlight with a shadow map as well.

I did a version with triangulated geometry..



Like I said: try Shadow Offset parameter, adjust slightly, with VPR on.




I made sure to "MERGE POINTS followed by UNIFY (POLYS)" with no change. It was reported that no points were eliminated, and no Polys has been eliminated.

After that you should verify Polygon Statistics to check whether there are 1-2 point polygons. Because Merge Points and Unify Polys can make them..

Dan Ritchie
01-19-2017, 03:18 PM
This is the "terminator issue" and not a bug. It's an artifact of rendering in any 3D program. Increase the number of polygons, or position the light so it's at a different angle.

Each spot on a polygon has a ray cast to determine if a shadow is falling there. Since polygons are actually flat, shadows can appear polygonal or receive errors at narrow angles with other polygons, even though their surface shading is smooth interpolated. The geometry itself is not smoothly interpolated. Hense, using more polygons, or changing the light angle, reduces the problems.

"Shadow offset" is designed to help with this. It causes the ray to be sent out from a spot slighly above the actual polygon spot being rendered.
It's on the object panel/render/

Greenlaw
01-20-2017, 02:06 PM
Sometimes I get weird cast shadows like that when the light is coming from a sharply glancing angle--typically, a mostly round object, like a human head being lit directly overhead. In this case, tweaking Shadow Offset in the object's Render tab may fix the issue. A small number usually does the trick but of course this depends on your object and lighting.

I'm almost sure this property is saved with the scene, not the object, but I'll have to check on that. (Just checked and, yes, it's a scene property.)

Dan Ritchie
01-21-2017, 09:55 AM
It's also super important to make your problem surface double sided, because polygons at sharp angles can trace shadows through the back side of nearby polygons, and you wont get proper shadows unless they're double sided. It doesn't sound like it makes sense, but just trust me, or try it for yourself.

MonroePoteet
01-21-2017, 12:10 PM
You might have some luck overcoming the terminator problem by bumping the Light's Shadow Map size way up, increasing Shadow Fuzziness, and increasing the Render Subpatch levels in the Object's Property page. Attached are a series of images showing the changes in parameters and the effects on the shadows. The "asteroid" was created using a tesselated sphere, jittering and subdividing (metaformed) twice.

Good luck!

mTp

135675 Default shadow map size of 512, fuzziness 1.0, subpatch levels 3

135676 Shadow map size of 8192, fuzziness 5.0, subpatch levels 3

135677 Closeup of 8192, 5.0, 3

135678 Closeup of 8192, 5.0, 10

135679 Midrange view of 8192, 5.0, 10