PDA

View Full Version : GLSL shaders



Andy Webb
09-24-2016, 07:04 AM
Transparency using the GLSL shaders in LW 15.3 and 11.6 is a big problem and I've had this problem for a while.

GLSL in LW9.6 is fine.

My question is, is it the graphics card or LW?

Either way can I reinstall the shaders and if so how?

Cheers

MichaelT
09-24-2016, 08:24 AM
What is the problem? I don't have any... not that I have been losing any thought over at least.

Andy Webb
09-24-2016, 08:33 AM
It's that transparency becomes just a jumble of pixelated boxes :confused:

134578

MichaelT
09-24-2016, 08:35 AM
Hmm weird... that looks like either two competing surfaces at the same location (like overlapping) or that the buffer isn't cleared in the renderer. Haven't seen that myself though.

MichaelT
09-24-2016, 08:42 AM
You could try and update your GFX card driver though.

Andy Webb
09-24-2016, 09:00 AM
It's just a cube with 50% transparency on it.

Just updated drivers for my card but no different.

Andy Webb
09-24-2016, 09:32 AM
I have now found that if I adjust the transparency using the little spinner beside the numerical panel it works until I release the mouse button! :confused::eek:

JoePoe
09-24-2016, 09:48 AM
Hi Andy,

You mean the shading Method, in prefs, right? Or are you talking about a specific shader?

What Numeric Panel? .....Surface editor?
(While I absolutely don't think you should be getting that weird result at all, Modeler isn't the best judge of surfacing.)
Although, fwiw, I don't get this in Modeler or Layout using GLSL (on mac).

Want to upload the object (as basic as it may be)?

Andy Webb
09-24-2016, 10:04 AM
Here's what happens...

134579

If I reset transparency to zero and do the same again I get the same problem, I also get this if I enter the amount using the keyboard.

MichaelT
09-24-2016, 10:27 AM
In display options.. does clicking on 'legacy OpenGL' help?

Andy Webb
09-24-2016, 10:42 AM
In display options.. does clicking on 'legacy OpenGL' help?

Yes it does but it is not very good

MichaelT
09-24-2016, 10:43 AM
True, and it is slower. But at least it solves the problem when you need to work.

Andy Webb
09-24-2016, 10:46 AM
Multitexture shaders work it's just that they are limited

JoePoe
09-24-2016, 10:51 AM
Sorry brother. I can't reproduce this. Only thing I can say is....... that ain't right :(.

Do you get the same in Layout (using GLSL)?

Tried flushing configs?

MichaelT
09-24-2016, 11:01 AM
A last resort would be if you are able to test a different gfx card? Because I still think it might be card related.

Andy Webb
09-24-2016, 11:03 AM
Yes the same in Layout.

What is frustrating is the if I turn OFF display transparency, adjust the transparency, then turn display transparency ON it shows up ok.

However as soon as I touch the transparency setting in the Surface Editor the problem comes back! :thumbsdow

Andy Webb
09-24-2016, 11:06 AM
Well I do need to buy a new card (when I get some money), just hope the issue is resolved then...

Cheers

MichaelT
09-26-2016, 01:09 PM
I did a bit of detective work regarding GTX660. And it seems it is suffering from a heating problem. So it could be that it is running a bit hot. If you are able, you can try and lower the memory and core clock by 25Mhz, and see if the forced lower speed will help cool it down a bit and solve your problems. I'm out of ideas if that doesn't work though.

Danner
09-27-2016, 08:17 AM
I tried this on 3 different machines where LW used to worke fine. Now it shows the garbled mess on reflection and transparency when using GLSshader mode, goes away using MultyTextureShaders or legacy OpenGL. As I said, it used to work before with this exact version of LW so it's either a windows or automatic nvidia driver update.

jwiede
09-27-2016, 02:45 PM
Now it shows the garbled mess on reflection and transparency when using GLSshader mode, goes away using MultyTextureShaders or legacy OpenGL. As I said, it used to work before with this exact version of LW so it's either a windows or automatic nvidia driver update.

Gfx drivers and their related software stacks accept and try to fix certain known issues in app-provided shader code. As those issues become less common, the driver stacks may subsequently receive updates that disable fixing such problems, to reduce surface/volume. As a result, it isn't safe to presume that shader problems are inherently due to problems in the OS or gfx driver software code.

MichaelT
09-27-2016, 03:17 PM
I tried this on 3 different machines where LW used to worke fine. Now it shows the garbled mess on reflection and transparency when using GLSshader mode, goes away using MultyTextureShaders or legacy OpenGL. As I said, it used to work before with this exact version of LW so it's either a windows or automatic nvidia driver update.

I have no idea why you experience the same issue on three different machines. Do you have the same issue even when creating a new scene? Or does this happen with this particular scene?

Andy Webb
09-28-2016, 05:12 AM
I tried this on 3 different machines where LW used to worke fine. Now it shows the garbled mess on reflection and transparency when using GLSshader mode, goes away using MultyTextureShaders or legacy OpenGL. As I said, it used to work before with this exact version of LW so it's either a windows or automatic nvidia driver update.

Well I'm sorry to here you are having this problem too.

But it is good to hear I'm not the only one

Danner
09-28-2016, 07:30 AM
Any object with with trasnparent surfaces.

spherical
10-05-2016, 11:19 PM
Well I'm sorry to here you are having this problem too.

But it is good to hear I'm not the only one

Nope. You're not the only one. Ran into it this week. Needed to position some text images mapped onto polys, turned Textured mode on in Perspective Viewport and saw what you did. WTF? MultiTexture allowed me to get the work done, but something sure is messed up. GTX970, here.

spherical
10-06-2016, 09:23 PM
Today I learned that this is not only limited to transparency. I turned Texture display mode on in one viewport and the expected surfaces having transparency showed the issue, but there are three surfaces that do not have transparency that also exhibit this. All of them are metallic, but zeroing values and turning off all layers in all channels makes no difference in the display. Other metallic surfaces in the model display normally; only these three have the issue. There has to be some common denominator, but what?

Andy Webb
10-07-2016, 02:34 AM
There definitely has to be something going on here.

As I said in my original LW9.6 works fine, I don't know about ver 10 but version 11 has the same problem!

spherical
10-07-2016, 08:56 PM
Just opened the same file in Modeler 2015.3-x86 on a different machine and the transparent surfaces display as expected; only the metals exhibit the issue.
Then, just to be thorough and pin this down that it's the video card - as the other workstation doesn't have an nVidia card, opened the file on the original workstation in Modeler 2015.3-x86. The transparent surfaces display as expected there, too, the metals still are psychedelic. So, now I have NO idea what the heck is going on.

EDIT: Not being one to leave stones unturned when something is Borked, I decided to pursue this further. Instead of disabling the two texture layers on Color and Specularity on one of these metals, I shift-clicked to remove the two textures. Display returned to normal. Went to a backup copy and copied the Color texture layer back into the original file. Display stayed looking good. Went and got the Specularity layer from the backup, hit the "T" to open and paste and the surface turned psychedelic without having pasted anything into it. Just hitting the button on Specularity, creating a texture having no content makes the display go wonky.

v10 x64 does not exhibit the issue. v11.6.2 x64 does.

Andy Webb
10-08-2016, 04:26 AM
Perhaps I'll try installing LW15.3 x86 and see what that has to offer.

I tried all sorts yesterday, all I could achieve was changes of colour on the psychedelic effect!

Andy Webb
10-09-2016, 09:01 AM
Just installed 2015.3 32bit loaded my test object and it looked fine, but as soon as I expanded the perspective viewport, bang same problem

:foreheads:(:hammer:

spherical
10-09-2016, 05:10 PM
So it was OK in quad viewport display, but the issue surfaced (not to make a pun) when going single viewport; without changing anything in the Surface Editor?

Andy Webb
10-10-2016, 03:23 AM
So it was OK in quad viewport display, but the issue surfaced (not to make a pun) when going single viewport; without changing anything in the Surface Editor?

Yes that's right

But of course it may have all gone Pear shaped if I had touched the Surface Editor, we will never know!

spherical
10-10-2016, 10:43 PM
Nvidia pushed a driver update. I installed it, then checked for the issue. Now, the display acts like the 32-bit on the Intel HD Graphics boxes. Transparent surfaces don't exhibit the problem; only the three metallic ones do.

Andy Webb
10-11-2016, 07:06 AM
Nvidia pushed a driver update. I installed it, then checked for the issue. Now, the display acts like the 32-bit on the Intel HD Graphics boxes. Transparent surfaces don't exhibit the problem; only the three metallic ones do.

Installed the latest NVidia driver but it made no difference.