View Full Version : NDI VLC Plugin Audio Issues

09-18-2016, 04:26 PM
I'm using Advanced Edition on a Tricaster Mini. When I play a video source via VLC on a laptop to NDI, the video plays fine, but the audio sounds like the wrong audio channel is playing. It sounds like the background channel. I've tried several videos and they all have the same audio issue. I've tired playing around in the mixer with no luck. If I play them with Audio and Video set to automatic on the laptop, I see and hear the clip playing properly.

Any thoughts what might be going on?


09-18-2016, 05:58 PM
What happens if you use NDI Monitor to listen? Does it have the same issue?

09-18-2016, 11:08 PM
Yes. I'm getting the same via NDI Monitor. VLC is pumping the surround track over NDI instead of the stereo channels. I don't see any way to select channel information to send.

09-19-2016, 09:25 AM
I don't have any clips with surround sound. There is an option to disable Dobly in VLC, maybe that will help? Otherwise, perhaps export out clips with only a stereo audio track?

09-19-2016, 11:42 AM
Where would I find the disable Dolby button for VLC playback? (At work, will check when I get home) I'm working with movie files to do a video tribute to Star Trek.

Thanks for the help!

09-19-2016, 12:48 PM
Tools > Preferences. Then in window that appears, go to Audio tab, option near bottom of list.

09-19-2016, 01:00 PM
Awesome! Thanks!

09-19-2016, 01:29 PM

So I downloaded the tools to test and I noticed I'm hearing the audio even though NDI is selected for output. I don't have the NDI monitor running. Shouldn't I hear nothing just like I see nothing until I turn on the monitor? I'm trying to work out expected results. I found the off selection for Dolby. Thanks again!

09-19-2016, 02:14 PM
Shouldn't hear anything on the local video or sound when using NDI. Did you quit and restart VLC after making the change? I think that VLC needs a restart if you change video or audio playback options.

09-19-2016, 03:56 PM
You are awesome at predicting where I'm screwing up.

Thank you sir.

09-19-2016, 04:44 PM
I know because I've done it myself! :)