PDA

View Full Version : LW 2015 Modeler Very Slow



lwanmtr
08-28-2016, 06:06 PM
Hey..so Im using LW on Winblows-10 with an Nvidia gtx-680, latest drivers and such...the perspective viewport is very slow..like 1 frame a second slow.

I've tried the different GL settings, but no difference...

Anyone know how to fix this?

Thanks

Just checked and Layout is also slow

MonroePoteet
08-29-2016, 05:18 PM
With my NVIDIA card, I had to explicitly tell the NVIDIA Control Panel to use the NVIDIA graphics card with Modeler and Layout. In the NVIDIA Control Panel (accessed by right-clicking on the desktop), there's a "Program Settings" tab, where you can indicate which graphics card is used for specific programs. The default is "Auto detect", which at least on my system causes it to use the built-in (slower) Intel graphics. By pressing the "Add" button, I navigated to the C:\Program Files\Newtek\<LWVersion>\bin\Modeler.exe and Layout.exe, added them in, and specific to use the NVIDIA graphics card.

mTp

lwanmtr
08-29-2016, 05:21 PM
I only have one card in this machine.

Dodgy
08-29-2016, 09:20 PM
Do you have a Colour Vmap on? That can be really slow.

lwanmtr
08-30-2016, 01:14 AM
Newp....Its sluggish even with no object loaded..add a box and it crawls. Im perplexed...lol

Lewis
08-30-2016, 01:16 AM
Slow with tumbling view or editing geometry ?

How many layers, how many surfaces ? Any transparent surfaces ... ?

lwanmtr
08-30-2016, 01:21 AM
Perspective is slow to turn about.... 1 layer, 6 polys, 1 surface....even an empty model is slow to spin the viewport around.

Lewis
08-30-2016, 01:23 AM
can you post model ?

lwanmtr
08-30-2016, 01:27 AM
Its running slow with nothing in it...no geometry at all.

Im not on my windows right now..but I can make a box tomorrow...lol. Seriously, since I installed 2015 in win 10 I havent actually loaded a model yet..lol.

Lewis
08-30-2016, 01:33 AM
well then it's somethign else wrong on drivers/hardware side or settings. Some stuff to try:

1. switch LWM CS to Linear (Disable)
2. Turn off openGL transparency
3. Switch settings to MTS + VBO mode (don't use GLSLS unless you really need it for some textures view)
4. Be sure Legacy openGL mode is OFF
5. Here is my win10 settings
134222

lwanmtr
08-30-2016, 01:39 AM
Yeah, I usually turn CS to linear. I've switched the GL settings, wasnt any difference. Even tried various settings in the nvidia control panel. Layout acted the same.

In modeler i generally only need to see color channel for uv mapping

Sensei
08-30-2016, 11:04 AM
Tried disabling waiting for vertical blank interrupt.. ?

lwanmtr
08-30-2016, 05:27 PM
In the nvidia controls?

lwanmtr
08-31-2016, 02:15 PM
I think I got it fixed. I turned off Threaded Optimization in the Nvidia control panel and Modeler is responding quickly now. Even with a large subd model.