View Full Version : bullet help

08-05-2016, 07:26 AM
I've got this one animation I'm trying to finish and struggling with Bullet, everything was working fine yesterday today got a small issue with kinetic shape.

I've got a bunch of shapes that cover a one kinetic shape(keyed) at some point the kinetic shape appears from the "pile" was working yesterday, today nothing happens, the mesh stays under the pile and I can see the numbers just change slightly on Y axis where it is animated but other than that it's not moving...

Anyone experienced something similar?

08-05-2016, 08:07 AM
Ahh, Bullet...

!st thought. Are you using the same version of LW? Identical settings seem to behave differently in every single version of LW, even the point releases.

2nd thought. Bake it! As soon as you have something half decent, bake it so you have a backup just in case. LW's Bullet engine does strange things, even minor setting tweaks can result in massive differences to the end result... Ooh, is that a butterfly?;)

3rd thought. Unless you need the new toys, use 11.6.3. It's much more stable, especially if you're on a Mac.

4th thought. Go through and eyeball all your settings from the saved scene. I once had a save that changed a glue setting from 100% to.001%...

5th thought. Download Houdini... :D

08-05-2016, 08:16 AM
Damn it, got half the project done-rendered it's the remaining part that need to be done and I don;t have time to transfer everything to other software.

I haven't changed any settings since yesterday where I rendered half of the sequence.

Good to know, well I might be moving everything to Maya and start from scratch FFS.


08-05-2016, 08:23 AM
Possible fix... I assume you tried resetting the sim, and that didn't work. If so, you could try changing the simulation step rate, run it, set it back how it was, then try again. I seem to remember that sorted something out that I was having an issue with in the dim and distant past...

08-05-2016, 08:29 AM
Nope, still the same even tho the object is keyframed it still stays under the pile and not even move.

08-05-2016, 08:48 AM
OK, I've got it.

Here's the issue - NEVER, EVER RE-run your sim if you have the time-scale envelope keyed! This will fu** the whole simulation and you will have to remove the envelope and key again.

08-05-2016, 08:50 AM
Your object is still set to Kinematic? Yes, I have done this... :D

- - - Updated - - -

Oh, well done. Hmm, that must be a 2015 peculiarity, I've never noticed it in 11.6.3, and as I don't have CS I use it a lot.

08-05-2016, 08:52 AM
Yup, key-ing the time scale now after the sim and re-running and works fine.
Haven't used the bullet that much in older version and honestly don't have time to play with installing older versions.


I guess my happined kicke-in too early.

Keyframing time scale affects the kinematic objects for some reason.