PDA

View Full Version : Problem with particles colliding with objects



AmigaNewTek
04-13-2016, 08:56 AM
Hello everyone,

i have some problems trying to simulate water flowing on a surface.

I have an emitter that drops particles (like a waterfall) on an irregular landscape.

How can i simulate the water flowing on gently sloping landscape?

Thank you very much.

AmigaNewTek
04-14-2016, 07:52 AM
Any hint?

I tried to set the landscape a "bounce" object, but the particles doesn't collides with the object. Maybe this doesn't work cause i created the landscape object with vue?
There are particular "constrain" with the kind of objects to use? It's due to the fact that the object is subpatched?

Please help

prometheus
04-14-2016, 08:11 AM
Any hint?

I tried to set the landscape a "bounce" object, but the particles doesn't collides with the object. Maybe this doesn't work cause i created the landscape object with vue?
There are particular "constrain" with the kind of objects to use? It's due to the fact that the object is subpatched?

Please help

Depends on what type of object the vue object is, you did export it to obj, lwo? a good advice is to save out to lwo anyway.
subpatch shouldnīt matter, there is a setting in the collision tab to use object subdiv...but it should work anyway in basic setups.

raise you radius/ level in the fx collision..try something really large to see it take effect.


also if you can post a simple setup of your scene or post images..do so.

AmigaNewTek
04-14-2016, 09:08 AM
Thank you for the reply.

I exported the object as lwo file. I tried with object subdiv too and tried with variuos radius size.

No results :-(

MonroePoteet
04-14-2016, 09:56 AM
Hard to say what's wrong with your scene file and objects unless you post them. If your ground object has "FX Collision" in the Properties=>FX tab applied, and the type is Bounce, the particles should "see" it and interact. I'd recommend using Object-Advanced as the Type, and I usually set the Bounce / Bind to 120-150% to have it bounce a little but then stick. I've attached a sample scene that took only a few minutes to set up.

If you're trying to simulate water over the surface, particles may not work very well. The issue is converting the particles into a fairly realistic water surface, which is normally done using Hypervoxels. Perhaps someone more expert has found a way to have HV's form a water-like surface, but I've played with it a lot and never found anything that blended the HV's well. The best approach I found was to use a combination of Y stretch of like 5% (to flatten the HVs vertically), a lot of particles, and Blend mode of Add. Even then, the surface was fairly "globular" and didn't look very much like flowing water. As I said, perhaps others have found a better HV setup for flowing water. IMO, HV's desperately need a "stretch to path" option, but since HV's are mostly spherical, that isn't an option.

An approach I've been fairly pleased with is to use a "water sheet" object with ClothFX. A very simple sample scene is attached demonstrating the technique. The ClothFX is applied to a low-resolution object for simulation, and the high-resolution object is attached to the low-res object via FX_Metalink. The hi-res object has the Dielectric material as it's surface texture, which requires things in the environment or the backdrop to reflect and refract.

I think most of the "conventional wisdom" is that if you want fluid effects, you need RealFlow or another fluid simulator. Apparently Blender fluids are pretty capable and can be exported to LW, but I don't know any details.

Good luck!
mTp

MonroePoteet
04-14-2016, 10:13 AM
I forgot to mention: to see the Water Sheet simulation, you'll have to press the Calculate button in the WaterSheet object's Properties=>FX tab. Let it run through the scene in wireframe mode to capture the simulation before going into VPR to see the water sheet Dielectric surface.

mTp

prometheus
04-14-2016, 10:21 AM
Thank you for the reply.

I exported the object as lwo file. I tried with object subdiv too and tried with variuos radius size.

No results :-(

How did you apply the collision fx to your object? you havenīt by any chance applied the new bullet dynamics? or tried to apply a seperate legacy collision object that isnīt connected to the object...I assume you have applied it within the terrain objects object properties in itīs fxtab? and applied it from the drop down menu?
Be aware of that you shall not use the fx tools bullet dynamics for particle collision like this.

AmigaNewTek
04-14-2016, 11:37 AM
Thank you both for the replies.

I tried in the way you've suggested, but no results.
I dindn't used the bullet dynamics for particle collision either.

I have a waterfall working colliding with the linked collision object. A second waterfall connected with the terrain doesn't work.

jeric_synergy
04-14-2016, 12:16 PM
Again, it's a lot easier to help you if you post samples.

prometheus
04-14-2016, 12:22 PM
Thank you both for the replies.

I tried in the way you've suggested, but no results.
I dindn't used the bullet dynamics for particle collision either.

I have a waterfall working colliding with the linked collision object. A second waterfall connected with the terrain doesn't work.

As jeric says...post sample, you are not giving us the whole context....you now say you had one working and another not working? waterfall connected? what is connected?
particle emitter isnīt connected to any collision or terrain..it just interacts with it..even if you have two emitters..they should both bounce on the terrain that has (linked) fx_collision applied.

or do you have two terrains with object collsion and two emitters? we really canīt analyze it properly this way..so unless you are restricted too..or itīs too much work, just post it and it will be easier to help..and much faster than spending time posting in uncertainty.

We are still here :)

AmigaNewTek
04-14-2016, 12:52 PM
Here's the terrain file.

I don't know if i can upload the waterfall scene, cause it's not mine.
Please verify if the terrain is the problem.

Thank you

MonroePoteet
04-14-2016, 02:40 PM
Yes, the Terrain object you posted seems confuse the collision detection in LW. I think the point order in the polygon mesh isn't what the collision detection is designed to detect. Not sure why it doesn't work, though.

To workaround the problem in the attached scene (with a modified / extended version of the Terrain object), I first selected the Valley in the Terrain where the waterfall would be and copied that into Layer2. Then, I selected the "Spring" portion (i.e. what will be the Emitter) at the head of the valley and copied that into Layer 3. In Layer 4, I created a 40x160 box that had approximately the same footprint as the Valley in the Y axis, then used Translate ("t") and Magnet (":") with right-mouse drag to change the influence range to move the various portions of that box into fairly close proximity of the equivalent portions of the Valley, trying to keep the grid square when looked at from above (this make the BG Conform to come work better). I cut away the portions of the box that were outside the Valley footprint, then used Modify=>Transform=>More...=>BG Conform to conform the points of the box to the actual point positions of the Valley.

Then, in Layout, hide layers 2,3 and 4. Set up Layer 3 (the "Spring") as the Emitter with appropriate parameters, and set up Layer 4 (the "Hidden Collision Object") as the Collision object (120% Bounce / Bind and Object-Subdiv as Type). It seems to work OK. Remember you need to press Calculate on the FX panel to calculate the particle motion. You can save the Motion in the File tab, but the saved motion file was too big to upload.

mTp

prometheus
04-14-2016, 02:43 PM
Here's the terrain file.

I don't know if i can upload the waterfall scene, cause it's not mine.
Please verify if the terrain is the problem.

Thank you

Turn off double sided in the surface editor in layout, switch to modeler and flip the polys, raise the collision radius to around 40-50, that worked for me...otherwise I had the same issue as you did...Edited..lower it back once you see collision starting to take effect, that radius is way to big..just for easier checking that the collision works.

I didnīt even mess with calculate button, only standard play button...but it works.

Michael

MonroePoteet
04-14-2016, 05:00 PM
Ooops! Good call, prometheus!

Attached is the same scene I posted before with the same hidden Collision object, except it's now Layer 2 with flipped polys. The point of the hidden Collision object is to increase the granularity of the mesh so you don't have to increase the collision radius. So, select the Valley, copy to Layer 2. Subdivide Metaformed a time or two (a step I forgot to mention in my previous post). Select the "Spring" region, copy to Layer 3. Same setup in Layout except now Layer 2 is the hidden collision object.

The purpose of using the "Calculate" button is if any parameters are changed in either the collision object or the emitter (or any other FX component). Yes, in a freshly loaded scene, the Play button will start calculation automatically. But, if you change parameters and they don't seem to be affecting the simulation, try the Calculate button.

As I said: good call, prometheus!

mTp

jeric_synergy
04-14-2016, 06:25 PM
....., try the Calculate button.
AND, you can make a hotkey for it, but you must search for "FX_Start", not "Calculate". FWIW, I use "alt+C", for "Calculate".

prometheus
04-14-2016, 07:14 PM
there already is a hotkey for calculate, check the modify/tools...so if you are standing in that tab, click ikb calculate button or ctrl-x, but a weird thing is that if using that hotkey, the particles isnīt showing during the process, while hitting the ikb calculate button does..weird.

AmigaNewTek
04-15-2016, 07:11 AM
Thank you all for the tips and informations.

Goind to do some tests...

AmigaNewTek
04-15-2016, 08:23 AM
Tried flipping polygons of the terrain and unchecking the double side and seems to works a little better. Another things i've done is to delete the emitter (that was cloned from the waterfall emitter) and recreate the emitter. The collision still non so clear and perfect as expected (water is passing through terrain)

AmigaNewTek
04-18-2016, 01:34 AM
Solved putting the particle size to 1 or 2 (was zero)

prometheus
04-18-2016, 10:01 AM
Solved putting the particle size to 1 or 2 (was zero)


great, I think I did that too..but I must have missed to forward that as well, I should have posted the scene back.