PDA

View Full Version : Help with emitter and object in scene



bellmore
04-12-2016, 07:02 PM
I added an emitter to my scene. When I move the emitter, an object in my scene moves with it. Am I doing something wrong?

https://www.youtube.com/watch?v=-w-39hlUpIQ

ernpchan
04-12-2016, 11:17 PM
Did you parent or constrain the object to the emitter?

jeric_synergy
04-13-2016, 12:30 AM
Is that an Object, or an object that is somehow related to the particles the Emitter emits?

If you're using Instancer:Particles, that may be the deal.

bellmore
04-13-2016, 08:13 AM
I opened the object in Layout. Then I added an emitter, which results in the object being tied to the emitter somehow. I've closed Modeler and Layout and re-opened them with the same results. I then started with a clean go at it. I modeled another object and loaded it straight from Modeler into Layout. I then added an emitter and it happens again. I've even completely uninstalled Lightwave, including all configs. After a fresh reinstall, the same thing happens.

ernpchan
04-13-2016, 08:38 AM
Can you post the scene file and objects?

bellmore
04-13-2016, 09:01 AM
Here are the scene and object files.
133407
133408

jeric_synergy
04-13-2016, 09:14 AM
There's a conceptual misunderstanding here. Here's the deal:

Your object has two layers, two meshes. You've applied an Emitter to one of those meshes, Layer2. Emitters cannot exist without an Object, even if it's just a null.

It's the Layer2 object you are moving, not the Emitter per se. In a sense, the object is the foundation for the emitter to exist.

Emitters are a PROPERTY of an object, so they are always going to be tied to their foundational mesh (or a null).

Note that the screen representation of the emitter may not be where the particles emit from. That is defined by the nozzle setting: could be Surface, Vertices, Normals, etc of the foundational mesh. The emitter icon is more of a placeholder.

MORE: another source of confusion here is your object is offset from the Origin, but the Emitter icon is centered at the origin. Unfortunately, and this was news to me, you can select the object by selecting the Emitter icon, and in this case the offset makes it appear that you've "selected the emitter". This is an illusion. You've selected the Layer2 object. Note that you can screen-select Layer1 only by clicking on its mesh, but you can select Layer2 by clicking on its mesh OR on the Emitter icon.

bellmore
04-14-2016, 08:52 AM
Thank you for the explanation, jeric_synergy. I've got everything worked out now.