PDA

View Full Version : UVMapping in ZBrush/Goz is driving me crazy.



Spinland
04-02-2016, 08:24 PM
I have a model in LW 2015.3 (for Mac) that has lots of weight maps and morphs. I send it to ZBrush using Goz, use UV Master to unwrap it, and then use Goz again to send it back to Modeler, and every time I send it back Goz insists on adding suffixes to the LWO file so it comes back as a new object with all of the weight maps and morphs stripped. If I unwrap it using the generic UV Map tool it seems to work fine, but as soon as UV Master comes into play the clean exchange falls apart. I want to use the advanced seam prevent painting but it appears there's no way to do it except to bring in a new LWO and then use a plugin to copy the maps and morphs over.

I've deleted all the files in the Pixologic default folder, cleared Goz cache, copied the model into a completely clean LWO file, and even completely uninstalled and re-installed ZBrush. No improvement. This is happening on two different Macs (and I re-installed on both of them to double check). I also tried unwrapping a clone and then pasting the UVs back into the original tool. Still cannot prevent Goz from adding a new suffix to the LWO so it goes in as a new object.

Is it common for UV Master to break Goz like this? Is there some way to get UV Master unwraps back into LW without losing maps and morphs?

Thanks in advance!

jasonwestmas
04-02-2016, 09:03 PM
I'm sure you probably know not to close your object file in lightwave when you send back the GoZ mesh to lightwave right? Obv. Goz doesn't save endomorphs to lwo format. It can only change your pre-existing endomorphs if one is selected in modeler when you send the sculpt data back to modeler.

Sounds like LW GoZ is still borked or your workflow is not correct. If your object was sent to Zbrush through GoZ, the LW endomorphs shouldn't disappear or change when you send the ZBrush model data back to the original LW model unless you have an endomorph selected in modeler.

What generic UV map tool are you talking about?

It's also an odd workflow to add or change UVs after you have setup morphs (I suspect you know this). If you have no other choice I would just do what you said and transfer the maps over to the GoZ model OR just use FBX format between lw and zb, it's less painful ime.

Spinland
04-03-2016, 05:00 AM
Morning, Jason! Thanks for responding.

So, first to address your questions. By the "generic UV tool" I meant this guy, here:

133241

Yeah, I agree that going back and re-mapping the UVs at this late point isn't a typical thing. What happened is that this is my first foray into using ZBrush to sculpt on a LW project, with polypaint and displacements, and with a standard manual unwrap via 3D Coat I saw some very ugly stretching around the neck when moving the head around:

133242

While it's probable (to me, at least) this has a lot to do with needing to extend the head weight map and blend the map edge with the torso better, I also noted a marked neck seam. I decided it would be interesting to go back and let ZBrush do the unwrap, preventing a neck seam, to observe how the stretching would behave differently (if it even would).

That's when the odd stuff began.

Just now I went back and went through my workflow from scratch using a simple test sphere with a weight map and a morph, and took several screen shots to illustrate what I'm seeing.

So, the LWO is now called test_v002.lwo, and I send it out via GoZ. These are my initial tools:

133243

So, I go into UV Master and click to work on a clone. Now these are my tools:

133244

Note how a _001 suffix has been added to the original tool. This behavior seems tied to what's going wrong. When I unwrap, copy the UVs, and paste to the now-renamed tool, going back to LW via GoZ results in a new object being opened instead of updating the original:

133245

This new object has been stripped of both weight maps and morphs but has the new UV map applied.

Next I tried to force ZBrush to go back to the original tool by manually loading the one first sent over via GoZ:

133246

With the original tool open, I again pasted the UVs over from the clone, then used GoZ to send (one would hope) back to the original LWO. Instead, this time I got a different kind of renaming of a new LWO object:

133247

Again, this new object was stripped of weight map and morph information but had the new UVs.

After this little experiment I took a look at the Default folder where ZBrush stores all its working files (path name is visible at the bottom):

133248

Lots of stuff there. I've tried both manually emptying this folder and clearing GoZ cache and neither action seems to have any effect.

So, that's where I stand now. I can, of course, use TA Tools to copy the maps and morphs over to the newly-unwrapped object file, but this behavior is very bothersome to me. It would seem either there's a step or three I'm failing to perform, or UV Master borks GoZ. If I unwrap the model using the "generic" tool I showed above none of these issues arise but I lose control over where the seams go unless I use poly groups or some other method. I could do that (in fact the workarounds for this issue are legion) but it doesn't seem as though the intended workflow is performing as it should and, as someone learning the ropes with ZBrush/GoZ, I feel it's important to understand where this process is going wrong.

Any ideas? Am I being a knucklehead or is there perhaps a problem here?

Spinland
04-03-2016, 05:04 AM
Oh, for the fun of it, here are the files from my little test:

133249

lertola2
04-03-2016, 08:57 AM
Instead of sending the object to zbrush by the goz button export it as an .obj file. Import that into zbrush and make your uv. For me at this point the object name does not change. Then goz back to lightwave. That worked for me.

The name change thing that zbrush is doing is very confusing. I seem to always run into little gotchas in the Lightwave goz workflow.

Spinland
04-03-2016, 09:23 AM
Thanks, I'll try that. Like I said, workarounds are many, and yours sounds like one of the faster ways I could try. I mainly posted to validate that I'm indeed seeing wonky behavior rather than something boneheaded on my part. :D

Thanks again!

Spinland
04-03-2016, 09:50 AM
I went ahead and sent a potential bug report to LW3DG. We'll see what they say.

jasonwestmas
04-03-2016, 10:18 AM
Definitely its a GoZ bug in my experiments today. My work around was to send the lwo from layout instead. Save out to Ztool Format inside of Zbrush. . . that seems to preserve the original name. Then send the object to layout instead of modeler. Then open that GoZ LWO inside of modeler to check to make sure your morphs and weights are still in tact.

If the append number is added to the GoZ lwo, rename the subtool back to the original name and try again. Seems to be hit or miss so I'm not 100% on what is going on. I'm glad you reported it.

FYI I am using Zbrush 4R7 P3 with ZBrush 2015.3.

Spinland
04-03-2016, 11:14 AM
Thanks, Jason. I'll try that method, too. Those are the same versions I'm running: 4R7P3 and 2015.3, on a Mac Pro running El Capitan. Got the same behavior on a MacBook Pro. The ZBrush installs are fresh as of yesterday, no config changes.

jasonwestmas
04-03-2016, 01:39 PM
ok! I have something that works every time and it isn't too painful.

-) Empty out your Zbrush cache or delete all the files in your "GoZ/ default" folder. I'm not sure where it is on macOS.

-) Send your model over to to Zbrush by pressing the I/O GoZ button.

-) The subtool model name should not have changed yet. Now press the "work on clone" button inside of UV Master.

-) Unwrap your "CL_ExampleName" Ztool model and copy the UVs.

-) Click on your original Ztool and you will see that the name has been appended with a "1". Rename it back to the original name and paste the UVs you have just copied.

-) After you rename and paste the UVs "Save As" your Ztool and find your "GoZ/ default" folder directory. Inside there you will find your original Ztool that the Modeler GoZ plugin created. Save/overwrite that file to replace it.

-) At this time it is safe to press the GoZ button to send back your new UV set to modeler.

-) Back in modeler you will see that a new UV set called ZBrushUVs has been added and all of your other VMaps will still be in tact.

Spinland
04-03-2016, 02:10 PM
Sweet. Thanks for all your effort on this, Jason! :I_Love_Ne

Spinland
04-04-2016, 08:08 AM
This is the response I just received on the bug report:

This issue has been addressed in the current internal builds of LightWave.

Thank you for your report.
--
LightWave 3D Group Support

[email protected]

jasonwestmas
04-04-2016, 10:43 AM
This is the response I just received on the bug report:

This issue has been addressed in the current internal builds of LightWave.

Thank you for your report.
--
LightWave 3D Group Support

[email protected]

lol well that doesn't help us now much. Fortunately it's not a show stopper imo.

At least we know we aren't crazy ;)

Spinland
04-04-2016, 10:49 AM
Heh. Yep! To be honest I find that most of the time I prefer the home-grown interaction to letting something like GoZ handle the details. I'm rather fussy about things like nodal textures and I'm just as good exporting all the maps plus the mesh and integrating them by hand. It'd be nice to have it fully functional for when time is pressing, though.

Just another reason to be looking forward to the next LW release.

jasonwestmas
04-04-2016, 12:52 PM
I think 3D coat is a fine choice as well for this kind of fast UV unwrapping. I like Headus UVLayout for really complex stuff but I think 3dcoat is my preferred UV toolset for 80% of my work.

That UV stretching issue you were having in the neck looks like you just need to give that loop some more UV space is all. Or it's an over lapping edge-loop messing things up.

But yeah GoZ is nice when it works for this type of situation.