PDA

View Full Version : Global illumination and shadows



Andy Webb
03-21-2016, 10:08 AM
Just run into an issue with luminous single sided polys used for global illumination.

I have a poly illuminating a sphere, the poly is unseen by camera and has all shadows turned off.

In VPR I get what I want but in an F9 render I'm still getting a shadow!

Any thoughts of a work round, is this a bug? :(

Cheers


133004133005133006

prometheus
03-21-2016, 01:26 PM
Just run into an issue with luminous single sided polys used for global illumination.

I have a poly illuminating a sphere, the poly is unseen by camera and has all shadows turned off.

In VPR I get what I want but in an F9 render I'm still getting a shadow!

Any thoughts of a work round, is this a bug? :(

Cheers


133004133005133006


you have a groundplane there too..isnīt that causing the shadow?
in 2015..I had no issues what so ever, just made it unseen by camera, and not even removed the recieive shadows., the ony issue I got...was instant crash trying to set up a scene in 2015..switching from vpr to final render..boy how instable it has been for me...anyway.

what else is illuminating..a gradient? another light active except for the luminous poly?

gerry_g
03-21-2016, 03:07 PM
on a mac but no crash in 2015 but I am on .3 revision may be time to put in the free update ? and I am habitually in 64 bit mode which I believe is more stable anyway

spherical
03-21-2016, 03:54 PM
Turning Indirect Bounces to 2, I get this:

133014

Getting rid of its shadow on the groundplane then requires turning on Directional Rays and using Monte Carlo not interpolated. Cast Shadow, Self Shadow and Receive Shadow on the lumipoly have no influence. Have to turn the samples up for a clean solution, but it works:

133015

Andy Webb
03-21-2016, 05:28 PM
Yes turning indirect bounces to 2 does make the difference.

It's a shame you can't turn shadows off for Global Illumination :(

Danner
03-21-2016, 05:51 PM
if you add 1% dissolve to luminous polygons unseen by camera you allow rays to pass through

spherical
03-21-2016, 05:52 PM
Well, GI is a different animal. Lumipolys are not lights. Lights are fake in comparison to GI; which is a replication of how light operates in the Real World, so turning shadows off for things doesn't compute, to make a pun. :) IOW, you can't turn shadows off for a given object in your living room.

spherical
03-21-2016, 05:57 PM
if you add 1% dissolve to luminous polygons unseen by camera you allow rays to pass through

Not working, here.

prometheus
03-21-2016, 06:03 PM
Weird..I just donīt get the problem, for me..using only that luminous poly, I do not get any shadows on it..with final render...so what am I doing wrong...or right :)

Andy Webb
03-22-2016, 03:39 AM
Well it does seem that switching "Directional Rays" on solves the problem of the shadow.

However I realised that in my rush to post this, the issue I was trying to point out got missed.
VPR in FULL render mode seems to respected the "Cast No Shadows" but did it really?

Is, in fact, VPR in full render mode only rendering one GI bounce even though it is set to two?

This could be why I got no shadow in VPR?

prometheus
03-22-2016, 08:01 AM
Well it does seem that switching "Directional Rays" on solves the problem of the shadow.

However I realised that in my rush to post this, the issue I was trying to point out got missed.
VPR in FULL render mode seems to respected the "Cast No Shadows" but did it really?

Is, in fact, VPR in full render mode only rendering one GI bounce even though it is set to two?

This could be why I got no shadow in VPR?

I just donīt get it why I do not have your problems, I can have bounce GI at a setting of 1,2,..or 3 ...but it still doesnīt produce a shadow artifact in the final renders...and I have no directional ray samples on either.
Why donīt you just post that fairly simple scene? so I can check the exact setup.

Andy Webb
03-22-2016, 08:25 AM
I just donīt get it why I do not have your problems, I can have bounce GI at a setting of 1,2,..or 3 ...but it still doesnīt produce a shadow artifact in the final renders...and I have no directional ray samples on either.
Why donīt you just post that fairly simple scene? so I can check the exact setup.

Here's the scene, this should give you a square shadow from the luminous poly near the ground plane. It should not be there in VPR and again it should disappear with "Directional Rays" on.

133038

Cheers

Danner
03-22-2016, 10:00 AM
I could not reproduce the error by myself either, but loading yours gives me the square shadow, I tried many settings and besides directional rays, the only thing that got rid of it (almost completely) was using dissolve on your luminous polygon, but not 1% as I had suggested, all the way to 40% it does dim it's influence accordingly tho. I had a large luminous polygon once where all the objects behind it would have crappy G.I. I got rid of the noise with just 1% dissolve on the luminous. But apparently this is a different beast.

Andy Webb
03-22-2016, 10:13 AM
When I put any sort of dissolve on the luminous poly the poly completely disappears and so does the GI!

Why should it work for you and not me? :(

Andy Webb
03-22-2016, 10:24 AM
Typical, just tried 40% dissolve on the poly and now it works, before I just got a black render!

prometheus
03-22-2016, 02:13 PM
finally got my own scene to produce the shadow..when messing with the ray per evaluation, and everything above 1 in the inderect bounces will produce the shadow.
so turning on directional rays will make it go away here, but it could also increase rendertimes drasticly.

spherical
03-22-2016, 04:45 PM
Well it does seem that switching "Directional Rays" on solves the problem of the shadow.

However I realised that in my rush to post this, the issue I was trying to point out got missed.
VPR in FULL render mode seems to respected the "Cast No Shadows" but did it really?

Is, in fact, VPR in full render mode only rendering one GI bounce even though it is set to two?

This could be why I got no shadow in VPR?

VPR has limitations in what it can do. It isn't always a 1:1 with F9/F10. It's in the docs and the section is posted in a thread, here, somewhere. LightWave Next will be a different situation, according to what we know now, where the two will be equal. For the time being, VPR should be "taken with a grain of salt" and F9 is the only true test.

<First Mate>And thirdly, VPR is more what you'd call "guidelines" than an actual render.</First Mate> :D

tburbage
04-13-2016, 08:23 PM
If I really understood the original setup, I also found that turning on Directional Rays was needed to get F9 and VPR to come up with a very similar solution. I had Unseen By Rays and Camera OFF, all shadow options off, Monte Carlo, Interpolated.

jwiede
04-17-2016, 05:42 PM
VPR has limitations in what it can do. It isn't always a 1:1 with F9/F10. It's in the docs and the section is posted in a thread, here, somewhere. LightWave Next will be a different situation, according to what we know now, where the two will be equal. For the time being, VPR should be "taken with a grain of salt" and F9 is the only true test.

<First Mate>And thirdly, VPR is more what you'd call "guidelines" than an actual render.</First Mate> :D

This seems more like "full-render" (F9/F10) misbehaving, though, rather than VPR lacking full feature-set of "full-render". Ask yourself this: Where is the shadow originating from in the "full-render", given the luminous poly's "Cast no shadow" setting?

This seems like a demonstration of "full-render" GI not properly obeying luminous poly "Cast no shadows" settings, and thus worth reporting as bug.

VPR is actually behaving in expected manner w.r.t. "Cast no shadows", though difficult to isolate whether because of limited VPR shadow support, or because VPR's actually handling "cast no shadows" properly.