PDA

View Full Version : FiberFX useles for animation



Boris Goreta
02-24-2016, 08:20 PM
I have a problem with FiberFX on deforming mesh. On a static mesh everything looks fine but when the mesh starts deforming fibers are starting to rotate around themselves and change shape making it look like it has a life of its own. Please look at this simple scene and you will see how fibers move on their own. Previously I thought that this is the issue only with MDD but it is the same with LW native bone deformation.

132563

Boris Goreta
02-24-2016, 10:10 PM
Also for some reason FiberFX style does not get saved with the scene. The style u get by using edit guides tool in the Layout viewport.

MAUROCOR
02-25-2016, 04:17 AM
Also for some reason FiberFX style does not get saved with the scene. The style u get by using edit guides tool in the Layout viewport.


I am shocked about the amount of bugs in FiberFX!!! They never end!
Regarding style, it should be saved with the object, not scene.
So, after creating/editing the style you want, be sure you save your object. It should work!

Boris Goreta
02-25-2016, 11:49 AM
Thanks for the tip about saving the guides, I didn't know it gets saved with the object.

OFF
02-25-2016, 04:08 PM
I have encountered the same problem - it is solved or bound hair (when it comes to partial cover) directly to the head bone or you can create a copy of an object, to cover its fibers and animate it through displacement via node Metafit (DPKit) - ie, it will repeat the deformation of its progenitor, but the deformation on his bones will not be carried out directly influence.

OFF
02-25-2016, 04:20 PM
The scene:132566

MAUROCOR
02-25-2016, 07:14 PM
Thanks for the tip about saving the guides, I didn't know it gets saved with the object.

Boris, another thing I noticed in your scene is the subdivision order of your object is FIRST when it should be LAST. I tried that way and it worked well, without fibers rotating around themselves.

Boris Goreta
02-25-2016, 07:33 PM
I changed it to last but the problem persist. Please see video.

132568

MAUROCOR
02-25-2016, 08:41 PM
I changed it to last but the problem persist. Please see video.

132568

I think you have to start working with the LAST option and then make what you have to do in FiberFX. Try to start the process again and it should work. At least it worked very well to me.

I have found something very interesting in the manual that says! "Fibers should be edited (using Edit Guides) in their undeformed state. Combing fibers must
be done before any deformation is applied, and before they are parented, moved or rotated in space.
Disabling Deformation, IK and Motion Controllers is a must."

jwiede
03-03-2016, 12:30 PM
I have found something very interesting in the manual that says! "Fibers should be edited (using Edit Guides) in their undeformed state. Combing fibers must
be done before any deformation is applied, and before they are parented, moved or rotated in space.
Disabling Deformation, IK and Motion Controllers is a must."

It's all well and good that the manual says that, but if that's a requirement for operation, then FFX should check for those conditions and (at least) put up a warning if they aren't met when combing, Edit Guides, etc. are activated. Particularly true when the required checking is neither simple nor direct for users -- in this case, users would need to check and dig through multiple layers of different editors/panels just to confirm the stated requirements before activating combing, not even close to a reasonable user expectation.

The current FFX design/implementation in this area deserves a "fail" for UX (and really QA/QC, as well), IMO. It's like handing someone scissors points-first, doing so invokes easily-avoidable risk.

Boris Goreta
03-03-2016, 01:13 PM
No this isn't it, I've tested this on static objects and it doesn't work.

I've also reported some of these issues 8 months ago via bug reporting system but didn't get a reply yet. I guess they are still evaluating this.