PDA

View Full Version : Illegal arithmetic operation on data type error!



Snosrap
02-01-2016, 09:43 AM
What the heck is this? It's screwing up my interface and causing VPR to run super slow. And how do I go about figuring this out? I'm assuming it's something wrong with my model. I will say it was fine until I added some weight maps to my model. This error only shows up with VPR running or when hit F9. It will finish rendering with F9, but I have to click through the dialog several times. Any help would be appreciated.

132154

ernpchan
02-01-2016, 10:30 AM
Do you have a script running or attached to something? It's complaining about a specific line of code in something.

prometheus
02-01-2016, 01:45 PM
are the weightmaps applied with nodes, maybe the node? connection isnīt correct?
try standard layering with weights..
try copy the object, but clear the weight maps and see if the issue persists.

Sensei
02-01-2016, 01:54 PM
Count quantity of requesters that you must to dismiss while F9 rendering.. Does it match quantity of threads set in Render Globals ? Try setting different threads value, and try again.

When node is receiving Init() it can return error,
when node is receiving NewTime() it can return error.

LW should show error msg to user.

I noticed in the past that when I returned error from them, VPR went crazy, and couldn't quit it (constant restart), had to close app in Task Manager, and remove all error handling from all my custom nodes.

Snosrap
02-01-2016, 01:56 PM
Thanks! It was a Shader I had attached. It was working fine when I attached it (Blotch) and was making some adjustments. Weird.