PDA

View Full Version : Bullet - forces - scaling spheres - help!



Cyberfish_Fred
01-08-2016, 02:54 AM
I did some tests with a couple of spheres, just for testing bullet/ forces.
See one of my tests here: https://vimeo.com/138722944

Question: As in my test animation, why can't I scale the spheres during time? How can I scale 1 or more of the spheres so that it still works with bullet/ forces?

Thanks!

Freddy

pinkmouse
01-08-2016, 04:31 AM
Scaling objects certainly doesn't work in 11.6.3 with Bullet, it only seems to calculate the collision hull on the first frame, then uses that through the simulation. Don't know about 12.

Have you tried a morph? The CA folks seen to use them all the time with cloth?

Cyberfish_Fred
01-08-2016, 06:00 AM
Thanks! Morphs also doesn't work, yes you can morph/scale them but for the collision it keeps the base shape.

Greenlaw
01-08-2016, 04:57 PM
If you set the object to Deforming, you can scale the object and it will collide with the scaled surface.

Greenlaw
01-08-2016, 05:00 PM
Wait...I take that back. I just checked and you're right, it doesn't work that way.

I'm almost sure I did something like this before but obviously that wasn't how. Let me look into this again and I'll get back to you.

Cyberfish_Fred
01-09-2016, 05:56 AM
Wait...I take that back. I just checked and you're right, it doesn't work that way.

I'm almost sure I did something like this before but obviously that wasn't how. Let me look into this again and I'll get back to you.

When you enable the dynamics, the scaling doesn't happen anymore....

Thomas Leitner
01-09-2016, 06:10 AM
....Question: As in my test animation, why can't I scale the spheres during time? How can I scale 1 or more of the spheres so that it still works with bullet/ forces?...


If you set the object to Deforming, you can scale the object and it will collide with the scaled surface.

Hi,
as Greenlaw wrote: set the object to deforming. But you also have to set Shape Retention to 100%, Linear and Angular Stiffness to 0% and Volume Conservation to 0%. Shape Lock should be set to none.

ciao
Thomas

Greenlaw
01-09-2016, 09:34 AM
Thanks for jumping in Thomas! I knew I had done this before but it's been a long time and I'd forgotten exactly how.

I just now tried again using your settings and it worked perfectly. It's the 'little' details that make the difference, doesn't it? :)

G

pinkmouse
01-09-2016, 01:00 PM
I know the CA bods would sort it! :)

jeric_synergy
01-09-2016, 02:05 PM
Thanks for jumping in Thomas! I knew I had done this before but it's been a long time and I'd forgotten exactly how.

I just now tried again using your settings and it worked perfectly. It's the 'little' details that make the difference, doesn't it? :)

G
Oy, glad you guys sorted that before I needed to use it.

BeeVee, you might want to add that particular procedure to the dox.