View Full Version : Odd Layout/Modeler crashes

12-27-2015, 12:51 PM
Hey all,

New issue i've run across. I can NOT have lightwave and modeler open anymore. If i launch one then the other, it will crash whatever was open. Aka Layouts open.. run modeler.. layout crashes. I've only made a few system changes.. of which i've reverted them all back (New nvidia drivers, etc) and its still happening.

I've disabled firewalls, windows defender, deleted ALL of my configs (and the entire config folder). Uninstalled and reinstalled 2015.3 and still doing int. Anyone see this before?

12-27-2015, 12:56 PM
Do you have VPR running while it happens?

Do you tried disabling hub?

Anyone see this before?

Only when VPR was running..
And in different LW version than yours.

12-27-2015, 01:03 PM

No VPR. Launched both with -0 option (so no hub). Its really strange.. and it just started happening outta the blue.

12-27-2015, 01:11 PM
Any new plugins added? Crashes at Startup or Shutdown can be plugin related... And hard to track down if it's a conflict between 2 plugins.

12-27-2015, 01:20 PM
I did a full reinstall, cleared all configs (when i uninstalled i checked the option to remove every thing). Manually deleted all newtek folders I COULD find and reinstalled. Still doing it.

I've also rolled back to drivers that were months old.. sequentially. Each one still causes the same issue. VERY annoying. I know its not lw related specifically.. but man its near impossible to work when you can't have layout/modeler open at the same time.

Interestingly i don't even get a LW crash reporter.. so its something system side causing the crash.

12-27-2015, 01:33 PM
Wow, that's a stumper. Have you tried LWG Support yet? They're actually very good.

Since they kill each other, it 'must' (says the non-programmer) be some resource(s) they are both trying to seize.....

My sympathies, sincerely: I'm just about to re-install to hopefully get HUB services, or F12 services at any rate, back. Even that speed-bump is a real drag-- not being able to run at all would be the pits.

12-27-2015, 01:39 PM
A quick update.. it seems that I'm having a DLL issue... MSVCR90.dll. I would have thought this would update correctly... but in my event logs i see this error..

Faulting application name: Layout.exe, version:, time stamp: 0x55c531d7
Faulting module name: MSVCR90.dll, version: 9.0.30729.9177, time stamp: 0x5615f352
Exception code: 0xc0000417
Fault offset: 0x00000000000552d4
Faulting process id: 0x2edc
Faulting application start time: 0x01d140e6524ea4a7
Faulting module path: C:\WINDOWS\WinSxS\amd64_microsoft.vc90.crt_1fc8b3b 9a1e18e3b_9.0.30729.9177_none_08e695a3a83b6ce3\MSV CR90.dll
Report Id: be9c4b2d-6e1f-4db9-881c-85433418b740
Faulting package full name:

Can't seem to remove that file because its in the accursed WinSXS folder. :| And i don't think updating any drivers will help either.. still digging.

12-27-2015, 02:02 PM
Restart computer.

Open LW folder.

Do you have there file

Make copy of MSVCR90.DLL,
the one mentioned in bug report.

And try running exe.

After install, check whether above file has been modified..

Try running..

ps. Check either 32 bit and 64 bit LW whether they both have problem..

12-27-2015, 02:08 PM
The event log is precisely the kind of thing LWG-CS needs to see. Of course, it's Sunday on xmas weekend, good luck!

12-27-2015, 02:38 PM
Do have those. Made a copy, and the update didn't patch those individual files. Its almost like these strange versions of the DLL's are overriding the system ones. How is that even possible? I can't delete them, and running the cleaner on the winsxs folder doesn't remove those files. :(

12-27-2015, 03:38 PM
Don't delete. Rename. Then try install from exe.

12-27-2015, 08:51 PM
Do you have a 3D mouse? If so, have it plug-in when starting LightWave. Switching between modeler or layout will crash if the 3D mouse is disconnected.

12-27-2015, 09:19 PM
Thanks for all the advice everyone. IN the end, i just used the Reset Windows functionality in win 10 to revert everything. Reinstalling LW fixed it. Somehow my visual studio distro's got mixed up and LW was referencing the wrong one. Even after uninstalling all the ones i had access to it was still doing it.

Anyways, all fixed up! APpreciate the help

12-27-2015, 10:14 PM
How does one determine which Visual Studio version is being used?

12-29-2015, 10:16 AM
Not sure @jeric_synergy... i could only tell that was what was causing the issue in the event viewer. It was hitting an odd dll that, for whatever reason, it shouldn't have been.