PDA

View Full Version : Mouse jumps to random position



Sanchon
12-22-2015, 02:33 AM
Developers please make something with this mouse bug ! Layout is the only software on the Earth where mouse jumps randomly to another position while moving. Moving mouse in Modeler is ok, so why not in Layout ?!

Sensei
12-22-2015, 03:39 AM
Check whether you have set Input Device Mouse.
I recall threads where people had it set to Tablet and complained.

Sanchon
12-22-2015, 03:53 AM
Check whether you have set Input Device Mouse.
I recall threads where people had it set to Tablet and complained.

This is old problem that was resolved in Win 8. I have Wacom Pen tablet and mouse connected to the same computer. Layout is the only software that has problem with it but only in Windows 10. Modeler works fine. Mouse jumps randomly I can't work :(

Sensei
12-22-2015, 03:56 AM
What if you disconnect tablet and restart computer?

What if you disconnect tablet, and use hard disk with Windows where there was never installed tablet drivers.. ?

Is your mouse separate?
Or it's mouse with tablet one package?

Try USB separate mouse whether it has problem too.

You didn't answer: did you try set Device Input to Mouse, to see whether it helps or not. Simply switch it. Restart. And check whether it jumps or not.

Sanchon
12-22-2015, 05:46 AM
Disconnecting, restarting - the same problem. I tried two mouses ( wirelles ) A4 tech and Logitech G700s - the same problem. Modeler works fine. If I set device to tablet - everything is ok but you know - moving mouse as tablet you go out of screen shortly.

I working with Photoshop and some others 3D softwares but Layout.exe is the only software in which my mouse pointer jumps like hell.

Sensei
12-22-2015, 05:47 AM
What if you disconnect tablet, uninstall tablet drivers, restart computer, and connect regular mouse.. ?

Tablet drivers are changing the way system works. They inject mouse events to system events queue. At least in the past they worked this way..

Sanchon
12-22-2015, 05:52 AM
What if you disconnect tablet, uninstall tablet drivers, restart computer, and connect regular mouse.. ?

Tablet drivers are changing the way system works. They inject mouse events to system events queue. At least in the past they worked this way..

I didn't tried it yet but why other software works fine, even modeler.exe but not layout.exe ?

Sensei
12-22-2015, 06:05 AM
You didn't specified in which moments mouse jumps.

But app has to set mouse coordinates f.e. while spinning/zooming/translating viewport after hiding cursor after clicking top-right icons.
Maybe it interferes with driver somehow.

If I can't reproduce it here, NewTek developers can't too, and it'll be never fixed the most likely. Corp developers never bother trying to fix something they cannot reproduce. Such bug reports are immediately shut-down. And message "can't reproduce, closed".
So you have to find a way to fix it by yourself.

Did you play with mouse acceleration settings to see how it changes, if anything?
https://www.youtube.com/watch?v=f55e3Sf79iY

How about different versions of Layout?

magiclight
12-24-2015, 03:56 PM
I use an Intuos 4 Pro and a mouse (Logitech G502), LW set to tablet mode and both mouse and pen work perfect without a single hickup (LW 2015.3) on windows 7, 8.1 and 10 (no problem with modeler or layout), so I am not so sure it's a bug in LW.

Possibly you might have something messed up for Wacom Layout specific settings as that is where you get the problem ?

Sanchon
01-04-2016, 09:59 AM
As I said, the problem is only when input device is set to mouse, not tablet. This is old problem - http://forums.newtek.com/showthread.php?138170-Cursor-Problem-(jumps-suddenly-out-of-position-after-clicking)&highlight=mouse+jumps and this is related only to Lightwave's Layout. All other software that I use ( including Modeler ) work fine.

Lewis
01-04-2016, 02:01 PM
As I said, the problem is only when input device is set to mouse, not tablet. This is old problem - http://forums.newtek.com/showthread.php?138170-Cursor-Problem-(jumps-suddenly-out-of-position-after-clicking)&highlight=mouse+jumps and this is related only to Lightwave's Layout. All other software that I use ( including Modeler ) work fine.

Mine jumps in modeler also BUT you have to be very fast and use shortcuts to see it. Like hit T and move mouse almost instantly. If you wait 1 sec after hitting shortcut (or use buttons instead shortcuts) then it works fine. It's almost like LW don't ract on time fast enough so then it jumps/executes command too much so cursor/movement/rotation jumps extra big amount.

Slartibartfast
01-05-2016, 09:52 AM
guess it won't hurt to try theese two tips:
1. Check that your pen is not to close to the tablet (I read someone had problems with that)
2. Mouse movement in LW was really messed up when I used screen scaling (4K screen that I wanted to have larger text on. Win 10) Try setting it to 100% if you have anything else.

Good luck!

Sanchon
01-05-2016, 10:36 AM
Thanks for comments, but this issue is related to multimonitor setup and Layout windows ( panels ) opened on 2nd monitor rather than Wacom tablet. I completely removed tablet and other mouse. More testing needed. Some time ago I and others have this issue on Win8 but it was resolved - now the same is on Win10. After clicking on a panel that is on another monitor ( for example surface editor ) and when I return to perspective viewport, there is 80% chance that my mouse jumps to another, random position.

Lewis
01-05-2016, 11:00 AM
I have 2 machines, one Win 7 and one Win8 and no difference, layout jumps mostly in camera view after "fit selected" and fast movements, modeler also in various situations. I have modeler panels all at 1 screen / no help.

Happens only in LW (i tested MAX, Blender, Adobe PS, AE, Pr, Il, few other tools and nowhere is that problem present. I even tried to change mouse (i had Logitech on both machines) but still no fix :(.