View Full Version : Interesting Rhiggit issue: Reduce Smart crashing Layout

12-12-2015, 06:39 PM
This seems to happen consistently for me. I was following the video about cleaning up foot slide and as soon as I got to that part, crash. I then re-tried it after manually deleting most of the keyframes thinking maybe it was a memory issue. No help.

I tried again using several different BVH files and they all crashed as well. Then I tried just creating a Rhiggit preset rig, no mesh, no mocap, just a few simple keyframed IK leg goal movements, and it still crashed Layout. I tried Reduce basic and that also crashed it. Very odd.

Attached is the (very basic) scene file that was my last attempt at testing, and which experienced the crashes for either of the Reduce operations.


EDITED TO ADD: this is Rhiggit 2.07, LW 2015.3 and OS X El Capitan.

12-12-2015, 06:45 PM
Addendum: just tried using only a cube object moving in X, and Flatten Holds crashed Layout as well. It's starting to look like the crash comes with any of the curve filters. Hope that helps.

12-12-2015, 06:50 PM
Addendum part Zwei. Last time I had issues with one plugin it was related to the presence of another. I just removed all of the third party plugins from my installation except the three RH folders and the crash still occurs for me. Just another hopefully useful data point.

12-12-2015, 07:35 PM
Okay, one more data point then I'm calling it a night. I can replicate the same behavior across multiple installations on different machines. The only thing I haven't yet tried is a Windows virtual machine. I have a Win7/64 VM available but it doesn't currently have LW installed and it's getting late here. I might have some time tomorrow to try that.

12-13-2015, 04:02 AM
No such bother here (on windows) could be a mac thing.

12-13-2015, 04:04 AM
Cool, thanks for the update. Going to try a Windows install asap to see what happens here.

12-13-2015, 05:13 AM
Okay, it's definitely just something in my "third_party" plugins folder. Your confirmation that all was well normally (as well as it not being stupidly late at night here now) gave me the flag to get medieval on this.

Win7 VM installation worked perfectly: check.

Full uninstall and re-install on one of my Macs, adding back in only Rhiggit plugin: check.

Second Mac test, existing LW installation but a full plugin delete, replace only the stock ones plus Rhiggit Pro: check.

Either a corrupted or conflicting plugin is almost certainly the culprit and of course that's my problem. The good news is all is now working perfectly so life is good. :-)